zoukankan      html  css  js  c++  java
  • hdu 1690 最短路floyd

    Bus System

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 5686    Accepted Submission(s): 1441

    http://acm.hdu.edu.cn/showproblem.php?pid=1690

    Problem Description
    Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
    The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



    Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
    To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
     
    Input
    The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
    Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
    Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
    In all of the questions, the start point will be different from the destination.
    For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
     
    Output
    For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
     
    Sample Input
    2
    1 2 3 4 1 3 5 7
    4 2
    1
    2
    3
    4
    1 4
    4 1
    1 2 3 4 1 3 5 7
    4 1
    1
    2
    3
    10
    1 4
     
    Sample Output
    Case 1:
    The minimum cost between station 1 and station 4 is 3.
    The minimum cost between station 4 and station 1 is 3.
    Case 2: Station 1 and station 4 are not attainable.
    #include<iostream>
    #include<math.h>
    #include<stdlib.h>
    using namespace std;
    __int64 p[110][110],q[110];
    #define inf -1
    __int64 l1,l2,l3,l4,c1,c2,c3,c4,n,m;
    __int64 ge(__int64 a)
    {
        if(a==0)
            return 0;
        if(a>0&&a<=l1)
            return c1;
        else if(a<=l2)
            return c2;
        else if(a<=l3)
            return c3;
        else if(a<=l4)
            return c4;
        else
            return -1;
    }
    int main()
    {
        __int64 t,i,j,k,num=0;
        cin>>t;
        while(t--)
        {
            cin>>l1>>l2>>l3>>l4>>c1>>c2>>c3>>c4;
            cin>>n>>m;
            for(i=1; i<=n; i++)
                cin>>q[i];
            for(i=1; i<=n; i++)
                for(j=1; j<=n; j++)
                {
                    __int64 kk=q[i]-q[j];
                    if(kk<0)
                        kk=-kk;
                    kk=ge(kk);
                    p[i][j]=kk;
                }
            for(i=1; i<=n; i++)
                for(j=1; j<=n; j++)
                    for(k=1; k<=n; k++)
                      if(p[j][i]!=-1&&p[i][k]!=-1)
                      {
                          if(p[j][k]>p[j][i]+p[i][k]||p[j][k]==-1)
                            p[j][k]=p[j][i]+p[i][k];
                      }
    
            cout<<"Case "<<++num<<":"<<endl;
            for(i=1; i<=m; i++)
            {
                __int64 a,b;
                cin>>a>>b;
                if(p[a][b]==-1)
                    cout<<"Station "<<a<<" and station "<<b<<" are not attainable."<<endl;
                else
                    cout<<"The minimum cost between station "<<a<<" and station "<<b<<" is "<<p[a][b]<<"."<<endl;
            }
        }
    }
    View Code
  • 相关阅读:
    LoadRunner脚本增强技巧之参数化(二)
    LoadRunner脚本增强技巧之参数化(一)
    LoadRunner脚本增强技巧之手动关联
    LoadRunner脚本增强技巧之自动关联
    LoadRunner录制用户操作
    Fiddler绕过前端直接和后台进行交互
    Android手机Fiddler真机抓包
    zabbix自定义监控项二
    zabbix自定义监控项一
    zabbix主机自动发现和监控
  • 原文地址:https://www.cnblogs.com/ainixu1314/p/3432170.html
Copyright © 2011-2022 走看看