zoukankan      html  css  js  c++  java
  • hdu 3172 并查集

    Virtual Friends

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3244    Accepted Submission(s): 945

    http://acm.hdu.edu.cn/showproblem.php?pid=3172

    Problem Description
    These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

    Your task is to observe the interactions on such a website and keep track of the size of each person's network.

    Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
     
    Input
    Input file contains multiple test cases.
    The first line of each case indicates the number of test friendship nest.
    each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
     
    Output
    Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
     
    Sample Input
    1
    3
    Fred Barney
    Barney Betty
    Betty Wilma
     
    Sample Output
    2
    3
    4
    输入格式
    while(cin>>t)
    {
         while(t--)
         {
             ...
         }
    }
    map 存储
    find 路径压缩
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<map>
    using namespace std;
    int fa[100010];
    int num[100010];
    void init()
    {
        for(int i=1; i<=100000; i++)
        {
            fa[i]=i;
            num[i]=1;
        }
    }
    int find(int a)
    {
        int tmp=a,r=a;
        while(fa[tmp]!=tmp)
            tmp=fa[tmp];
        while(fa[a]!=tmp)
        {
            r=fa[a];
            fa[a]=tmp;
            a=r;
        }
        return tmp;
    }
    void unon(int a,int b)
    {
        int fa1=find(a);
        int fb1=find(b);
        if(fa1==fb1)
            cout<<num[fa1]<<endl;
        else
        {
            num[fa1]+=num[fb1];
            fa[fb1]=fa1;
            cout<<num[fa1]<<endl;
        }
    }
    int main()
    {
        int t,n,i,j;
        char s[25],ss[25];
        while(cin>>t)
        {
            map<string ,int >p;
            int mm=1;
            while(t--)
            {
                init();
                cin>>n;
                for(i=1; i<=n; i++)
                {
                    scanf("%s%s",s,ss);
                    if(!p[s])
                        p[s]=mm++;
                    if(!p[ss])
                        p[ss]=mm++;
                    unon(p[s],p[ss]);
                }
            }
        }
    }
    View Code
  • 相关阅读:
    后端指路手册(建议收藏):一文告诉你后端都要学习什么?应该从哪里学起!
    《Java 编程思想四》最新中文版,附下载地址!
    大厂面试必问的 4 大开源框架,你真的就懂了吗?
    借花献佛!朋友干了5年整的Java面试官,给我分享了一份面试官最爱问的Java面试题
    字节跳动总结的设计模式 PDF 火了,完整版开放下载!
    java
    java
    java
    java
    关于public class
  • 原文地址:https://www.cnblogs.com/ainixu1314/p/3446502.html
Copyright © 2011-2022 走看看