zoukankan      html  css  js  c++  java
  • 1036. Boys vs Girls (25)

    题目如下:

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    
    Sample Output 1:
    Mary EE990830
    Joe Math990112
    6
    
    Sample Input 2:
    1
    Jean M AA980920 60
    
    Sample Output 2:
    Absent
    Jean AA980920
    NA
    

    题目很简单,只需要定义Person结构体存储信息,建立男、女两个vector容器分别容纳各条记录,然后按照题目要求排序,最后按照要求输出即可,注意在输出时判断是否男、女容器都不空,有空的要输出Absent和NA。

    #include <iostream>
    #include <vector>
    #include <algorithm>
    
    using namespace std;
    
    struct Person{
    
        string name;
        char gender;
        string ID;
        int grade;
    
        Person(string _n, char _gen, string _id, int _grade) : name(_n), gender(_gen), ID(_id), grade(_grade) {}
    
    };
    
    int compareF(Person a, Person b){
        return a.grade > b.grade;
    }
    
    int compareM(Person a, Person b){
        return a.grade < b.grade;
    }
    
    int main()
    {
        vector<Person> males, females;
        int N;
        cin >> N;
        string name,id;
        char gender;
        int score;
        for(int i = 0; i < N; i++){
            cin >> name >> gender >> id >> score;
            if(gender == 'M'){
                males.push_back(Person(name,gender,id,score));
            }else{
                females.push_back(Person(name,gender,id,score));
            }
        }
        Person *m = NULL;
        Person *fm = NULL;
        if(males.size() != 0){
            sort(males.begin(),males.end(),compareM);
            m = &males[0];
        }
        if(females.size() != 0){
            sort(females.begin(),females.end(),compareF);
            fm = &females[0];
        }
    
        if(fm != NULL){
            cout << fm->name << " " << fm->ID << endl;
        }else{
            cout << "Absent" << endl;
        }
        if(m != NULL){
            cout << m->name << " " << m->ID << endl;
        }else{
            cout << "Absent" << endl;
        }
        if(fm != NULL && m != NULL){
            cout << (fm->grade - m->grade) << endl;
        }else{
            cout << "NA" << endl;
        }
    
        return 0;
    }
    


  • 相关阅读:
    ubuntu16.04编译安装PHP7.0.9,Nginx1.10,Phalcon3.1扩展
    阿里云云大使推广产品集合
    mysql性能优化-慢查询分析、优化索引和配置
    Js学习笔记(二)
    Javascript学习笔记(一)
    HashMap
    JDK 1.8 新特性
    Java转型
    Java IO
    Java正则表达式
  • 原文地址:https://www.cnblogs.com/aiwz/p/6154156.html
Copyright © 2011-2022 走看看