zoukankan      html  css  js  c++  java
  • 1029. Median (25)

    题目如下:

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output

    For each test case you should output the median of the two given sequences in a line.

    Sample Input
    4 11 12 13 14
    5 9 10 15 16 17
    
    Sample Output
    13
    

    题目非常简单,只需要输出两个集合并集的中位数(索引取下整),我的解决办法是把所有元素压入vector,然后调用sort函数得到非降序,(vector容量-1)/2 这个索引对应的就是要找的中位数。

    #include <iostream>
    #include <vector>
    #include <algorithm>
    #include <stdio.h>
    
    using namespace std;
    
    int main()
    {
        vector<long int> setA;
        int N;
        cin >> N;
        long int value;
        for(int i = 0; i < N; i++){
            scanf("%ld",&value);
            setA.push_back(value);
        }
        cin >> N;
            for(int i = 0; i < N; i++){
            scanf("%ld",&value);
            setA.push_back(value);
        }
        sort(setA.begin(),setA.end());
        cout << setA[(setA.size() - 1)/2] << endl;
        return 0;
    }
    




  • 相关阅读:
    centos7&redhat7修改密码
    memcached安裝部署文檔
    cronolog安装部署文檔
    ftp安裝部署文檔
    cacti安裝部署文檔
    php安裝部署文檔
    MYSQL-5.5安装部署文档
    MySQL5.1安裝部署文檔
    nginx進階
    IO进程疏漏
  • 原文地址:https://www.cnblogs.com/aiwz/p/6154163.html
Copyright © 2011-2022 走看看