zoukankan      html  css  js  c++  java
  • POJ2139--Six Degrees of Cowvin Bacon(最简单Floyd)

    The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 

    The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

    The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 

    Input

    * Line 1: Two space-separated integers: N and M 

    * Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 

    Output

    * Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 

    Sample Input

    4 2
    3 1 2 3
    2 3 4
    

    Sample Output

    100
    

    Hint

    [Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .] 
     
     
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    
    int way[305][305];
    
    int main(){
        int n,m;
        cin>>n>>m;
        int temp[305];
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                way[i][j]=INT_MAX;
                if(j==i)
                    way[i][i]=0;
            }
        }
        for(int i=0;i<m;i++){
            int num;
            cin>>num;
            for(int j=0;j<num;j++){
                cin>>temp[j];
            }
            
            for(int j=0;j<num;j++){
                for(int w=j+1;w<num;w++){
                    way[temp[j]][temp[w]]=way[temp[w]][temp[j]]=1;
                }
            }
        }
        
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                for(int w=1;w<=n;w++){
                    if(way[j][i]!=INT_MAX&&way[i][w]!=INT_MAX)
                        way[j][w]=min(way[j][w],way[j][i]+way[i][w]);
                }
            }
        }
        int ans=INT_MAX;
        for(int i=1;i<=n;i++){
            int t=0;
            for(int j=0;j<=n;j++){
                t+=way[i][j];
            }
            ans=min(ans,t);
        }
        cout<<ans*100/(n-1); 
        return 0;
    }
  • 相关阅读:
    C#使用cookie记住密码 逆水行舟
    Datable快速转换为List集合 逆水行舟
    C# EF 使用 (CodeFirst模式) 逆水行舟
    第一道用结构体解决的问题
    特殊回文数字
    简单贪心题(看最多的电视节目)
    Where is the Marble? (寻找大理石上的数字)
    关于Application Designer的概述
    怎样学习Peoplesoft byl vhonglei
    group by的使用说明
  • 原文地址:https://www.cnblogs.com/albert67/p/10330601.html
Copyright © 2011-2022 走看看