zoukankan      html  css  js  c++  java
  • POJ2456--Aggressive cows(Binary Search) unsolved

    Description

    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

    Input

    * Line 1: Two space-separated integers: N and C 

    * Lines 2..N+1: Line i+1 contains an integer stall location, xi

    Output

    * Line 1: One integer: the largest minimum distance

    Sample Input

    5 3
    1
    2
    8
    4
    9

    Sample Output

    3

    Hint

    OUTPUT DETAILS: 

    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

    Huge input data,scanf is recommended.
     
     
    #include<iostream>
    #include<numeric>
    #include<algorithm>
    using namespace std;
    int pos[100005];
    int n,c;
    int C(int d){
        int last=0;
        for(int i=1;i<c;i++){
            int cur=last+1;
            while(cur<n&&pos[cur]-pos[last]<d)
                cur++;
            if(cur==n)
                return false;
            last=cur; 
        }    
        return true;    
    }
    int main(){
        cin>>n>>c;
        for(int i=0;i<n;i++)
            cin>>pos[i];
        sort(pos,pos+n);
        int lb=0,ub=*max_element(pos,pos+n);
        int mid=(ub-lb)/2;
        while(ub-lb>=0){
            if(C(mid)){
                lb=mid+1;
            }
            else{
                ub=mid-1;    
            }
            mid=(lb+ub)/2;
        }
        cout<<mid<<endl;
        return 0;
    }
  • 相关阅读:
    设计模式(三)--观察者模式
    设计模式(二)--单例模式
    tornado 资源
    复习 网络通信协议
    设置允许远程连接MySQL (Ubuntu为例)
    ubuntu 下安装ssh服务
    Python 运算内建函数
    py知识点拾遗之sort(),sorted(),reverse(),reversed()
    SQLite安装 以及 SQLite header and source version mismatch错误解决 (In debian)
    debian折腾笔记
  • 原文地址:https://www.cnblogs.com/albert67/p/10386019.html
Copyright © 2011-2022 走看看