zoukankan      html  css  js  c++  java
  • 贪心 没什么可以说的,还是要注意细节

                                                                                                            Moving Tables
    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem. 
     

    Input

    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above. 
     

    Output

    The output should contain the minimum time in minutes to complete the moving, one per line. 
     

    Sample Input

    3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
     

    Sample Output

    10 20 30
    就是移动桌子,移动一次10min,我就排序Y大到小,一样在排X。
    需要注意的是4 5 6 7算两次因为5和6在同一个地方详细的见上图和表格

    #include<stdio.h>
    #include<string.h>
    main()
    {
    int i,n,m,g,t,sum,max,min;
    int x[300];
    int y[300];
    int z[300];
    scanf("%d",&n);
    while(n--)
    {
    scanf("%d",&m);
    sum=0;
    memset(z,0,sizeof(z));
    for(i=1;i<=m;i++)
    {scanf("%d %d",&x[i],&y[i]);
    if(x[i]>y[i])
    {
    t=x[i];
    x[i]=y[i];
    y[i]=t;
    }}
    for(i=1;i<m;i++)
    for(g=i+1;g<=m;g++)
    {
    if(y[i]<y[g])
    { t=x[i];
    x[i]=x[g];
    x[g]=t;
    t=y[i];
    y[i]=y[g];
    y[g]=t; }
    }
    for(i=1;i<m;i++)
    for(g=i+1;g<=m;g++)
    {
    if(y[i]==y[g]&&x[i]<x[g])
    { t=x[i];
    x[i]=x[g];
    x[g]=t;}
    }
    for(i=1;i<m;i++)
    {max=x[i];
    if(z[i]==0){
    for(g=i+1;g<=m;g++)
    {
    if(y[g]<=max&&z[g]==0){
    if(max-y[g]==1&&y[g]%2==1)
    z[g]=0;
    else{z[g]=1;max=x[g];}
    }
    }
    sum++; } }
    if(z[m]==0)
    sum++;
    printf("%d ",sum*10);
    }
    }

     
  • 相关阅读:
    小毛病,大问题
    [zz]Libvirt 虚拟化库剖析
    libvirt XML 学习笔记
    Ubuntu 10.04下使用 libvirt 创建KVM虚拟机
    [zz]使用libvirt管理kvm虚拟机(更新中)
    [zz]LXC:Linux 容器工具
    一些比较好的URL
    [zz]Libvirt XML学习笔记
    [zz]一些KVM xml 例子
    [zz]kvm环境使用libvirt创建虚拟机
  • 原文地址:https://www.cnblogs.com/alexanderone/p/3869789.html
Copyright © 2011-2022 走看看