zoukankan      html  css  js  c++  java
  • 好烦,水题花了那么长时间还做不出来,然后。。。。就没有然后了。。。。

    h Jesus! The Minecraft Server of XadillaX's came across a bug!
    There's one way to solve this bug in game. That is to get a bucket of water and a bucket of lava and mix them to obsidian. But remember, you must get water first, or the server will explode! Boom~
    Fortunately there is a row of buckets at front of Hungar, he can save the world!


    Some of buckets are filled with water and some are lava. Remember that Hungar can only move forward, that means when Hungar move to one bucket, he can't move back to the buckets behind this bucket. And he must get water first.
    Now give you the sort of buckets, please help Hungar to calculate out that how many ways he can save the world.

    Input

    This problem contains several cases because of the XIONG HAI ZI, Minary. 
    The first line of each case contains one integer N (0 < N ≤ 1000000) which indicates the number of buckets. 
    Next line follows N buckets in from near to far which `W` indicates water and `L` indicates lava. 

    Output

    For each case, output the ways Hungar can save the Minecraft world.

    Sample Input

    5
    W L W L L
    3
    W W L
    

    Sample Output

    5
    2

    #include<stdio.h>
    main()
    {
    int n,i,m,sum,t,p;
    char x[1000100];
    char y[1000100];
    while(scanf("%d",&n)!=EOF)
    {sum=0;t=0;p=0;
    for(i=1;i<=n;i++)
    scanf("%s",&x[i]);
    for(i=1;i<=n;i++)
    {
    y[i]=x[n-i+1];
    }
    for(i=1;i<=n;i++)
    {
    if(y[i]=='W')
    {
    sum=sum+i-1;
    p=p+t;
    t=t+1;
    }
    }
    printf("%d ",sum=sum-p);
    }return 0;
    }

    不知道自己哪里错了,排序暴力直接超时,找到规律居然WA,先放着吧。。。。。

  • 相关阅读:
    设计手稿: 搜索引擎
    软件版本介绍
    VS2012中使用编译的Qt-5.1.1静态库开发程序
    POJ2236(并查集)
    Java关键字this的用法总结
    paip.提升用户体验-----c++ gcc 命令在notepad++扩展中的配置..
    MySQL基本查询语句练习
    [置顶] 提升代码内外部质量的22条经验
    mysql 数据库复制表 create table city1 like city;
    两个脚本
  • 原文地址:https://www.cnblogs.com/alexanderone/p/3925058.html
Copyright © 2011-2022 走看看