zoukankan      html  css  js  c++  java
  • 暑假集训每日一题0718(动规)

    Description

    You are in the world of mathematics to solve the great "Monkey Banana Problem". It states that, a monkey enters into a diamond shaped two dimensional array and can jump in any of the adjacent cellsdown from its current position (see figure). While moving from one cell to another, the monkey eats all the bananas kept in that cell. The monkey enters into the array from the upper part and goes out through the lower part. Find the maximum number of bananas the monkey can eat.

                                                                   

     

    Input

     Input starts with an integer T (≤ 50), denoting the number of test cases.

    Every case starts with an integer N (1 ≤ N ≤ 1000). It denotes that, there will be 2*N - 1 rows. The ith (1 ≤ i ≤ N) line of next N lines contains exactly i numbers. Then there will be N - 1 lines. The jth (1 ≤ j < N) line contains N - j integers. Each number is greater than zero and less than 2^15.

    Output

     For each case, print the case number and maximum number of bananas eaten by the monkey.

    Sample Input

    2
    4
    7
    6 4
    2 5 10
    9 8 12 2
    2 12 7
    8 2
    10
    2
    1
    2 3
    1

    Sample Output

    Case 1: 63
    Case 2: 5
     

    典型的动态规划题,跟数字三角形类似。
    由于内存比较卡,所以要用滚动数组优化。
    View Code
    #include <stdio.h>
    #include <string.h>
    #define N 1005
    #define MAX(a,b) ((a)>(b)?(a):(b))
    int a[2][N];
    int main()
    {
        int t,n,i,j,id,kase=0;
        scanf("%d",&t);
        while(t--)
        {
            memset(a,0,sizeof(a));
            scanf("%d",&n);
            id=0;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=i;j++)
                {
                    scanf("%d",&a[id][j]);
                }
                for(j=1;j<=i;j++)
                {
                    a[id][j]+=MAX(a[id^1][j-1],a[id^1][j]);
                }
                id^=1;
            }
            for(i=n-1;i>0;i--)
            {
                for(j=1;j<=i;j++)
                {
                    scanf("%d",&a[id][j]);
                }
                for(j=1;j<=i;j++)
                {
                    a[id][j]+=MAX(a[id^1][j],a[id^1][j+1]);
                }
                id^=1;
            }
            printf("Case %d: %d\n",++kase,a[id^1][1]);
        }
        return 0;
    }
  • 相关阅读:
    C# 根据二级栏目Id查询出所属文章的信息列表
    C#网站首页制作MVC
    C#Mvc退出登录
    C#Mvc修改密码
    C#网站开发之内容页Content
    C#Mvc登录功能
    Linux命令——shell
    学习笔记cisco常用命令
    性能相关术语
    Linux命令(一)
  • 原文地址:https://www.cnblogs.com/algorithms/p/2597729.html
Copyright © 2011-2022 走看看