zoukankan      html  css  js  c++  java
  • HDOJ三部曲-DP-1017-pearls

    Pearls

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
    Total Submission(s) : 22   Accepted Submission(s) : 12
    Problem Description
    In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the prices remain the same. For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.
    Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.
     
    Input
    The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.
     
    Output
    For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.
     
    Sample Input
    2 2 100 1 100 2 3 1 10 1 11 100 12
     
    Sample Output
    330 1344
     
     
     
    状态转移方程 dp[i]=min(dp[i],dp[j]+(sum_num(j+1...i)+10)*va[i])
     
     
     
     
    #include<iostream>
    #include<algorithm>
    using namespace std;
    #define INF 999999999
    struct pearl
    {
    	int num,va;
    }p[101];
    
    int cmp(const pearl &p1,const pearl &p2)
    {
    	if(p1.va<p2.va)
    		return 1;
    	else
    		return 0;
    }
    
    int main()
    {
    	int n;
    	cin>>n;
    	while(n--)
    	{
    		int i,j,k,c,dp[101];
    		cin>>c;
    		for(i=1;i<=c;i++)
    		{
    			cin>>p[i].num>>p[i].va;
    			dp[i]=INF;
    		}
    		dp[0]=0;
    		sort(p,p+c,cmp);
    		for(i=1;i<=c;i++)
    		{
    			for(j=0;j<=i;j++)
    			{
    				int total=0;
    				for(k=j+1;k<=i;k++)
    					total+=p[k].num;
    				if(dp[j]+(total+10)*p[i].va<dp[i])
    					dp[i]=dp[j]+(total+10)*p[i].va;
    			}
    		}
    		/*for(i=0;i<=c;i++)
    			cout<<dp[i]<<endl;*/
    		cout<<dp[c]<<endl;
    	}
    }
    
     
     
     
     
  • 相关阅读:
    linux下一个网卡配置多个ip(转)
    实验室生活:第一个月
    关闭或开启Linux上的iptables防火墙,SSH端口(转)
    TcpTrace追踪远程服务器的soap信息
    我的mysql学习笔记(1)mysql的安装
    大型网站架构演变和知识体系[转载]
    ms sql一些有用的语句
    我的mysql学习笔记(2)mysql基本的命令
    SQL Server 2008 R2数据库镜像部署[转]
    C++ 自定义动态数组模板
  • 原文地址:https://www.cnblogs.com/aljxy/p/3306916.html
Copyright © 2011-2022 走看看