zoukankan      html  css  js  c++  java
  • HDOJ-三部曲-1001-Flip Game

    Flip Game

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
    Total Submission(s) : 44   Accepted Submission(s) : 17
    Problem Description
    Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
    1. Choose any one of the 16 pieces. 
    2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
    Consider the following position as an example:
    bwbw wwww bbwb bwwb Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
    bwbw bwww wwwb wwwb The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
     
    Input
    The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
     
    Output
    Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
     
    Sample Input
    bwwb bbwb bwwb bwww
     
    Sample Output
    4
     
    Source
    PKU
     
     
    通过这个题我对搜索的应用和利用位运算对状态进行记录的方法有了更深的认识。
    将每种棋盘状态用一个二进制数来记录,通过异或运算模拟每次翻面操作。先用1表示黑色棋子,0表示白色棋子,将棋盘表示成一个16位的二进制整数(0到65535之间),创建一个队列,将当前棋盘的状态(用一个0到65355之间的整数表示)进队,然后将对队头的16种可能的操作(用异或运算和移位运算完成)产生的情况(用一个0到65355之间的整数表示)进队,然后队头元素出队,再对此时的对头元素重复进行该操作......注意每次进队操作都要用bool数组对该种情况进行标记,如果产生相同的情况就说明有能达到该种状态更快捷的方法,就不入队,用一个整型的step数组记录每次操作所需的步数......循环直至队头指针等于队尾指针或者出现全黑或全白的状态(即65535和0),输出impossible或者步数。
     
    //#include<iostream>
    //using namespace std;
    //int binary(int a[])
    //{
    //	int i,t=1,res=0;
    //	for(i=1;i<=16;i++)
    //	{
    //		res+=a[i]*t;
    //		t*=2;
    //	}
    //	return res;
    //}
    //void copy(int a[],int b[])
    //{
    //	int i;
    //	for(i=1;i<=16;i++)
    //		b[i]=a[i];
    //}
    //int main()
    //{
    //	
    //	int i,j,a[17],b[17],t=0,front=0,rear=0,step[65536]={0};
    //	int **queue=new int*[65536*2];
    //	for(i=0;i<65536;i++)
    //		queue[i]=new int[17];
    //	bool f[65536]={false};
    //	char sq[4][5];
    //	step[0]=0;
    //	for(i=0;i<4;i++)
    //	{
    //		cin>>sq[i];
    //		for(j=0;j<4;j++)
    //		{
    //			if(sq[i][j]=='w')
    //				a[t+j+1]=0;
    //			else
    //				a[t+j+1]=1;
    //		}
    //		t+=4;
    //	}
    //	int tm=binary(a);
    //	/*for(i=1;i<=16;i++)
    //		cout<<a[i]<<' ';
    //	cout<<endl;
    //	cout<<binary(a)<<endl;*/
    //	/*cout<<binary(a)<<endl;*/
    //	if(tm==0||tm==65535)
    //	{
    //		cout<<0<<endl;
    //		return 0;
    //	}
    //	f[tm]=true;	
    //	copy(a,queue[rear++]);
    //	while(front<rear)
    //	{
    //		int t=binary(queue[front]);
    //		copy(queue[front],b);
    //		for(i=1;i<=16;i++)
    //		{					
    //			b[i]=1-queue[front][i];
    //			if(i>4)
    //				b[i-4]=1-queue[front][i-4];
    //			if(i<13)
    //				b[i+4]=1-queue[front][i+4];
    //			if(i%4!=1)
    //				b[i-1]=1-queue[front][i-1];
    //			if(i%4!=0)
    //				b[i+1]=1-queue[front][i+1];
    //			int temp=binary(b);
    //			if(temp==0||temp==65535)
    //			{
    //				cout<<step[t]+1<<endl;
    //				return 0;
    //			}
    //			if(!f[temp])
    //			{
    //				step[temp]=step[t]+1;
    //				f[temp]=true;
    //				copy(b,queue[rear++]);
    //			}
    //		}
    //		front++;
    //	}
    //	cout<<"Impossible"<<endl;
    //	for(i=0;i<65536;i++)
    //		delete queue[i];
    //	delete queue;
    //}
    
    
    #include<iostream>
    using namespace std;
    int main()
    {	
    	int i,j,a=0,b,t=1,front=0,rear=1,step[65536]={0},queue[65536*2];
    	bool f[65536]={false};
    	char sq[5];
    	for(i=0;i<4;i++)
    	{
    		cin>>sq;
    		for(j=0;j<4;j++)
    		{
    			if(sq[j]=='b')
    				a+=t;
    			t<<=1;
    		}
    	}
    	if(a==0||a==65535)
    	{
    		cout<<0<<endl;
    		return 0;
    	}
    	queue[0]=a;
    	f[a]=true;
    	while(front<rear)
    	{
    		int t=queue[front];
    		for(i=0;i<16;i++)
    		{
    			b=queue[front];			
    			b^=1<<i;
    			if(i+1>4)
    				b^=1<<(i-4);
    			if(i+1<13)
    				b^=1<<(i+4);
    			if((i+1)%4!=1)
    				b^=1<<(i-1);
    			if((i+1)%4!=0)
    				b^=1<<(i+1);
    			if(b==0||b==65535)
    			{
    				cout<<step[t]+1<<endl;
    				return 0;
    			}
    			if(!f[b])
    			{
    				step[b]=step[t]+1;
    				f[b]=true;
    				queue[rear++]=b;
    			}
    		}
    		front++;
    	}
    	cout<<"Impossible"<<endl;
    }
    
  • 相关阅读:
    设置toad for oracle命令行自动补全
    toad安装oracle客户端过程
    如何设置oracle表空间自动扩展
    centos7平台安装python3
    oracle监听报The listener supports no services
    各平台下oracle-instant-client安装部署
    Oracle工具(Oracle Tools) – RDA(RemoteDiagnostic Agent)
    centOS7下安装GUI图形界面
    Linux 系统健康巡检脚本
    oracle 巡检脚本(自动化)
  • 原文地址:https://www.cnblogs.com/aljxy/p/3327161.html
Copyright © 2011-2022 走看看