zoukankan      html  css  js  c++  java
  • poj 1276 完全背包

    poj 1276
    Cash MachineTime Limit: 1000MS
    Memory Limit: 10000KTotal Submissions: 18242
    Accepted: 6364

    Description

    A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 
    N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 
    means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 
    Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 
    Notes: 
    @ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

    Input

    The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 
    cash N n1 D1 n2 D2 ... nN DN 
    where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

    Output

    For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

    Sample Input

    735 3 4 125 6 5 3 350633 4 500 30 6 100 1 5 0 1735 00 3 10 100 10 50 10 10

    Sample Output

    73563000

    Hint

    The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 
    In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 
    In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

    Source

    Southeastern Europe 2002

     

    Run IDUserProblemResultMemoryTimeLanguageCode LengthSubmit Time9848681guzhoudiaoke1276Accepted776K47MSG++1118B2012-02-25 17:32:579308589guzhoudiaoke1276Accepted780K579MSGCC827B2011-09-12 23:52:36

     

    1) 579MS

    /*
     * poj 1276
     * guzhoudiaoke@126.com
     * 2011-09-12
     */
    #include <stdio.h>
    #include <string.h>
    #define MAX    100000
    int dp[MAX+1];
    int main()
    {
        int cash, N, i, j, k, nk[11], dk[11];
        
        while (scanf("%d%d", &cash, &N) != EOF)
        {
            for (i = 1; i <= N; i++)
                scanf("%d%d", &nk[i], &dk[i]);
            
            if (cash == 0 || N == 0) {
                printf("0\n");
                continue;
            }
            
            memset(dp, 0, sizeof(dp));
            dp[0] = 1;
            
            int found = 0;
            for (i = 1; i <= N && !found; i++)
                for (j = cash; j >= 0 && !found; j--)
                    if (dp[j] == 1)
                        for (k = 1; k <= nk[i] && j+dk[i]*k <= cash; k++)
                        {
                            dp[j + dk[i]*k] = 1;
                            if (j + dk[i]*k == cash) 
                                found = true;
                        }
            
            int i = cash;
            while (dp[i] == 0)
                i--;
            printf("%d\n", i);
        }
        
        return 0;
    }

     

     

    2)47MS

    /*
     * poj 1276
     * 采用更类似多重背包的方法
     * 孤舟钓客
     * 2012-02-25 16:22
     */
     
    #include <stdio.h>
    #include <string.h>
    #define MAX 100000
    int dp[MAX+1];
    int inline max(int a, int b)
    {
        return a > b ? a : b;
    }
    void solve(int cash, int N, int nk[], int dk[])
    {
        int i, j, k;
        for (i = 1; i <= N; i++) {
            if (dk[i] * nk[i] >= cash) {    /* 该物品总数超过容量, 完全背包 */
                for (j = dk[i]; j <= cash; j++)
                    dp[j] = max(dp[j], dp[j-dk[i]]+dk[i]);
            }
            else {    /* 多重背包 */
                k = 1;
                while (k < nk[i]) {
                    for (j = cash; j >= k*dk[i]; j--)
                        dp[j] = max(dp[j], dp[j-dk[i]*k] + dk[i]*k);
                    nk[i] -= k;
                    k *= 2;
                }
                for (j = cash; j >= nk[i]*dk[i]; j--)
                    dp[j] = max(dp[j], dp[j-dk[i]*nk[i]] + dk[i]*nk[i]);
            }
        }
    }
    int main()
    {
        int cash, N, i, j, k, nk[11], dk[11], found, t;
        
        while (scanf("%d%d", &cash, &N) != EOF)
        {
            for (i = 1; i <= N; i++)
                scanf("%d%d", &nk[i], &dk[i]);
                
            if (cash == 0 || N == 0) {
                printf("0\n");
                continue;
            }
            
            memset(dp, 0, sizeof(dp));
            
            solve(cash, N, nk, dk);
            
            printf("%d\n", dp[cash]);
        }
        
        return 0;
    }


  • 相关阅读:
    hdu 1518 square
    AWR报告的使用
    状态模式之观察者和状态模式
    Arduino笔记五三轴陀螺仪L3G4200D
    TCP IP 学习笔记 二 链路层
    机房收费系统数据库设计小结
    TMSSCRIPTER介绍
    TMSScripter语法
    listview的一些用法
    进制转换
  • 原文地址:https://www.cnblogs.com/amourjun/p/5134196.html
Copyright © 2011-2022 走看看