zoukankan      html  css  js  c++  java
  • uva-100-The 3n + 1 problem

    http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=36 

    The 3n + 1 problem 

    Background

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    The Problem

    Consider the following algorithm:

      		1. 		 input n 

    2. print n

    3. if n = 1 then STOP

    4. if n is odd then tex2html_wrap_inline44

    5. else tex2html_wrap_inline46

    6. GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given nthis is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

    The Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    You can assume that no operation overflows a 32-bit integer.

    The Output

    For each pair of input integers i and j you should output ij, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    Sample Input

    1 10 
    100 200 
    201 210 
    900 1000 

    Sample Output

    1 10 20 
    100 200 125 
    201 210 89 
    900 1000 174

     解题思路:题目的意思是让你求出在n到m之间进行3n+1计算步数最大的数,由于n达到100W,所以暴力的方法会超时,我们首先想到的就是打表预处理1到100W每个数字进行3n+1操作的步数,然后直接求n到m之间的max步数即可。

    关于3n+1问题请走任意门-》http://en.wikipedia.org/wiki/Collatz_conjecture

     1 #include <stdio.h>
     2 
     3 #define MAXN 1000100
     4 
     5 int a[MAXN];
     6 
     7 int fun(long long n){
     8     int res = 1;
     9     while(1){
    10         if(n == 1){
    11             break;
    12         }
    13         if(n%2 == 0){
    14             n/=2;
    15         }
    16         else{
    17             n = 3 * n + 1;
    18         }
    19         res++;
    20     }
    21     return res;
    22 }
    23 
    24 int main(){
    25         int n, m, i, t, ans, x, y;
    26         for(i = 1; i < MAXN; i++){
    27             a[i] = fun((long long)i );
    28         }
    29         while(scanf("%d %d", &n, &m) != EOF){
    30             x = n, y = m;
    31             if(n > m){t = n, n = m, m = t;};
    32             ans = -1;
    33             for(i = n; i <=m; i++){
    34                 ans = ans > a[i] ? ans : a[i];
    35             }
    36             printf("%d %d %d ", x, y, ans);
    37         }
    38         return 0;

    39 } 

  • 相关阅读:
    DDGScreenShot--iOS 图片处理--多图片拼接 (swift)
    DDGScreenShot--iOS 图片裁剪,切圆角,加边框,你还用cornerRadius,还有更高级的用法
    DDGScreenShot — 复杂屏幕截屏(如view ScrollView webView wkwebView)
    使用python测试框架完成自动化测试并生成报告-实例练习
    python测试框架 pytest
    python测试用框架unittest & HTMLTestRunner
    Git远程仓库及分支管理
    Git基本使用
    python基础练习题
    协议抓包分析工具介绍
  • 原文地址:https://www.cnblogs.com/angle-qqs/p/4069298.html
Copyright © 2011-2022 走看看