zoukankan      html  css  js  c++  java
  • Let the Balloon Rise

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 59081    Accepted Submission(s): 21724


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5 green red blue red red 3 pink orange pink 0
     
    Sample Output
    red
    pink
     
    循环遍历之前的输入即可
     
    #include<stdio.h>
    #include<string.h>
    int x;
    int g[1000];
    char s[1000][1000];
    int fx(char* a)
    {
         int i;
         for(i=0;i<x;i++)
         {
             if(strcmp(a,s[i])==0)
             {g[i]++;return 0;}
         }
         strcpy(s[x],a);
         g[x]=1;
         x++;
         return 0;
    }
    int main()
    {
         char a[1000];
         int i,n,v,max;
         while(scanf("%d",&n)!=EOF&&n!=0)
         {
             getchar();
             x=0;
             for(i=0;i<n;i++)
             {
                 gets(a);
                 fx(a);
             }
             max=0;
             for(i=0;i<x;i++)
             {
                 if(g[i]>max){max=g[i];v=i;}
             }
             printf("%s ",s[v]);
         }
         return 0;
    }
  • 相关阅读:
    水晶报表关于System.Web.Extensions报错的问题
    个人下一步学习计划
    一个老程序员对数据库的一点纠结
    Visual SourceSafe权限配置记录
    SQL SERVER 2008代码折叠小技巧
    用命令行自动备份数据库到其他服务器
    CrystalReports 2008序列号留档
    ····
    C语言中的static
    页面自动刷新的几种方法
  • 原文地址:https://www.cnblogs.com/anhuizhiye/p/3315945.html
Copyright © 2011-2022 走看看