Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59081 Accepted Submission(s): 21724
Problem Description
Contest
time again! How excited it is to see balloons floating around. But to
tell you a secret, the judges' favorite time is guessing the most
popular problem. When the contest is over, they will count the balloons
of each color and find the result.
This year, they decide to leave this lovely job to you.
This year, they decide to leave this lovely job to you.
Input
Input
contains multiple test cases. Each test case starts with a number N (0
< N <= 1000) -- the total number of balloons distributed. The next
N lines contain one color each. The color of a balloon is a string of
up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For
each case, print the color of balloon for the most popular problem on a
single line. It is guaranteed that there is a unique solution for each
test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
循环遍历之前的输入即可
#include<stdio.h>
#include<string.h>
int x;
int g[1000];
char s[1000][1000];
int fx(char* a)
{
int i;
for(i=0;i<x;i++)
{
if(strcmp(a,s[i])==0)
{g[i]++;return 0;}
}
strcpy(s[x],a);
g[x]=1;
x++;
return 0;
}
int main()
{
char a[1000];
int i,n,v,max;
while(scanf("%d",&n)!=EOF&&n!=0)
{
getchar();
x=0;
for(i=0;i<n;i++)
{
gets(a);
fx(a);
}
max=0;
for(i=0;i<x;i++)
{
if(g[i]>max){max=g[i];v=i;}
}
printf("%s ",s[v]);
}
return 0;
}
#include<string.h>
int x;
int g[1000];
char s[1000][1000];
int fx(char* a)
{
int i;
for(i=0;i<x;i++)
{
if(strcmp(a,s[i])==0)
{g[i]++;return 0;}
}
strcpy(s[x],a);
g[x]=1;
x++;
return 0;
}
int main()
{
char a[1000];
int i,n,v,max;
while(scanf("%d",&n)!=EOF&&n!=0)
{
getchar();
x=0;
for(i=0;i<n;i++)
{
gets(a);
fx(a);
}
max=0;
for(i=0;i<x;i++)
{
if(g[i]>max){max=g[i];v=i;}
}
printf("%s ",s[v]);
}
return 0;
}