zoukankan      html  css  js  c++  java
  • How Many Tables

    How Many Tables

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 8   Accepted Submission(s) : 3

    Font: Times New Roman | Verdana | Georgia

    Font Size:

    Problem Description

    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

    Input

    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

    Output

    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

    Sample Input

    2
    5 3
    1 2
    2 3
    4 5
    
    5 1
    2 5
    

    Sample Output

    2
    4

    并查集,找出多少个集合

    #include<stdio.h>
    int father[1005],depth[1005];
    void init()
    {
        int i;
        for(i = 1; i < 1005;i ++)
        {
            father[i] = i;
            depth[i] = 0;
        }
    }

    int find(int x)
    {
        if(x==father[x])
            return x;
        else
            return father[x] = find(father[x]);
    }

    void unit(int x,int y)
    {
        x = find(x);
        y = find(y);
        if(x==y)
            return ;
        if(depth[x]<depth[y])
        {
            father[x] = father[y];

        }
        else
        {
            if(depth[x]>depth[y])
                father[y] = father[x];
            else
            {
                father[x] = father[y];
                depth[y]++;
            }
        }
    }

    int main()
    {
        int T,n,m,gr,j,a,b;
        scanf("%d",&T);
        while(T--)
        {
            gr = 0;
            init();
            scanf("%d%d",&n,&m);
            while(m--)
            {
                scanf("%d%d",&a,&b);
                unit(a,b);
            }
            for(j = 1;j <= n;j ++)
            {
                if(j == father[j])
                    gr++;
            }
            printf("%d ",gr);
        }
        return 0;
    }


  • 相关阅读:
    Tensorflow之MNIST机器学习入门
    MongoDB学习第七篇 --- sql和mongodb对比
    MongoDB学习第六篇 --- Delete操作
    MongoDB学习第五篇 --- Update操作
    MongoDB学习第四篇 --- Query操作
    MongoDB学习第三篇 --- Insert操作
    MongoDB学习第二篇 --- Mac下通过 Shell 执行 mongo 命令
    MongoDB学习第一篇 --- Mac下使用HomeBrew安装MongoDB
    python连接sql server数据库实现增删改查
    转。webapp开发小tips
  • 原文地址:https://www.cnblogs.com/anhuizhiye/p/3315948.html
Copyright © 2011-2022 走看看