zoukankan      html  css  js  c++  java
  • Hay Points

    Hay Points

    TimeLimit: 1 Second   MemoryLimit: 32 Megabyte

    Totalsubmit: 1022   Accepted: 602  

    Description

    Each employee of a bureaucracy has a job description - a few paragraphs that describe the responsibilities of the job. The employee's job description, combined with other factors, such as seniority, is used to determine his or her salary.

    The Hay Point system frees the Human Resources department from having to make an intelligent judgement as to the value of the employee; the job description is merely scanned for words and phrases that indicate responsibility. In particular, job descriptions that indicate control over a large budget or management over a large number of people yield high Hay Point scores.

    You are to implement a simplified Hay Point system. You will be given a Hay Point dictionary and a number of job descriptions. For each job description you are to compute the salary associated with the job, according to the system.

    Input

    The first line of input contains 2 positive integers: m <= 1000, the number of words in the Hay Point dictionary, and n <= 100, the number of job descriptions. m lines follow; each contains a word (a string of up to 16 lower-case letters) and a dollar value (a real number between 0 and 1,000,000). Following the dictionary are the n job descriptions. Each job description consists of one or more lines of text; for your convenience the text has been converted to lower case and has no characters other than letters, numbers, and spaces. Each job description is terminated by a line containing a period.

    Output

    For each job description, output the corresponding salary computed as the sum of the Hay Point values for all words that appear in the description. Words that do not appear in the dictionary have a value of 0.

    Sample Input

    7 2
    administer 100000
    spending 200000
    manage 50000
    responsibility 25000
    expertise 100
    skill 50
    money 75000
    the incumbent will administer the spending of kindergarden milk money
    and exercise responsibility for making change he or she will share
    responsibility for the task of managing the money with the assistant
    whose skill and expertise shall ensure the successful spending exercise
    .
    this individual must have the skill to perform a heart transplant and
    expertise in rocket science
    .

    Sample Output

    700150
    150

     

    保存事先输入的字符串,在文本中对每个单词进行对比,也是水题,注意细节就行

     

    #include<stdio.h>

    #include<string.h>

    char str[1010][20];int sum;

    int main()

    {
    int m,t,i,b[20];
    char c[100]={'a'};
    scanf("%d %d",&m,&t);
    getchar();
    for(i =0;i < m;i++)
    scanf("%s %d",str[i],&b[i]);
    getchar();
    while(t--)
    {
    sum =0;
    while(strcmp(c,".")!=0)
    {
    scanf("%s",c);
    for(i =0;i < m;i++)
    if(strcmp(c,str[i])==0)
    {
    sum+=b[i];
    break;
    }
    }
    getchar();
    memset(c,48,sizeof(c)-1);
    printf("%d ",sum);
    }
    return0;}

  • 相关阅读:
    shell test -n -z
    java -d64
    shell export
    topngroupcollector
    stat 查看文件修改时间
    随机30道小学计算题02(修改)
    设计四则运算2程序单元测试用例
    学习进度02
    随机30道小学计算题02
    随机30道小学计算题01
  • 原文地址:https://www.cnblogs.com/anhuizhiye/p/3316080.html
Copyright © 2011-2022 走看看