zoukankan      html  css  js  c++  java
  • Ignatius and the Princess III

    Ignatius and the Princess III

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10312    Accepted Submission(s): 7318


    Problem Description
    "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

    "The second problem is, given an positive integer N, we define an equation like this:
      N=a[1]+a[2]+a[3]+...+a[m];
      a[i]>0,1<=m<=N;
    My question is how many different equations you can find for a given N.
    For example, assume N is 4, we can find:
      4 = 4;
      4 = 3 + 1;
      4 = 2 + 2;
      4 = 2 + 1 + 1;
      4 = 1 + 1 + 1 + 1;
    so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
     
    Input
    The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
     
    Output
    For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
     
    Sample Input
    4 10 20
     
    Sample Output
    5 42 627
     
    思路:一开始拿到这个题目以为是找规律,有递推关系什么的,最后找了好长时间没找到规律,上网查了一下才发现是用母函数做,就是把数的加法和指数乘法的幂的加法联系起来,母函数:G(x)=(1+x+x^2+x^3+x^4+.....)*(1+x^2+x^4+x^6+....)*(1+x^3+x^6+x^9+....)*... ,x^n的系数就是n的拆分方案数!其实这个不难理解,因为x^n的系数是多少就表明有多少个x^n相加得来,换句话说就是有多少种x的幂之和的拼凑方案,即本题所求。
     
    #include<stdio.h>
    int a[125],b[125];   // a[i]表示x^i的系数,为临时值,b[i]表示x^i的系数,为最终值;
    int main()
    {
        int i,j,k,n;
        for(i = 0;i <= 125;i ++)
        {
            a[i] = 0;
            b[i] = 1;
        }
        for(i = 2;i <= 125;i ++)
        {
            for(j = 0;j <= 125;j ++)
            {
                for(k = 0;k+j <= 125; k += i)
                    a[k+j] += b[j];      //因为x^(k+j)是从x^j得来的,故它的系数应该在原有系数的数值的基础上加上x^j                 
                          的系数(这是关键的重点!!!这就是为什么我们要用两个数组的目的) }
    for(j = 0;j <= 125;j ++) { b[j] = a[j]; a[j] = 0; } } while(~scanf("%d",&n)) printf("%d ",b[n]);
      return 0;
    }
  • 相关阅读:
    SSM商城项目(二)
    SSM商城项目(一)
    Solr
    Lucene
    TP5分页函数paginate中的each()传参
    微信小程序+php 授权登陆,完整代码
    thinkphp5 + barcode 生成条形码
    微信小程序-获取当前位置和城市名
    PHP查询附近的人及其距离的实现方法
    thinkphp5连接sql server
  • 原文地址:https://www.cnblogs.com/anhuizhiye/p/3328530.html
Copyright © 2011-2022 走看看