zoukankan      html  css  js  c++  java
  • Calendar Game HDU

    Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid. 

    A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game. 

    Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy. 

    For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years. 

    InputThe input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001. 
    OutputPrint exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO". 
    Sample Input

    3 
    2001 11 3 
    2001 11 2 
    2001 10 3 

    Sample Output

    YES 
    NO 
    NO 

    大意:

    从当前日期,一个玩家在他可以移动到下一个日程表日期或下个月的同一天。当下个月没有同一天的时候,玩家只会移动到下一个日历日期。例如,从1924年12月19日,你可以移动到1924年12月20日,下一个日历的日期,或1925年1月19日,下一个月的同一天。但是,从2001年1月31日起,您只能移动到2001年2月1日,因为2001年2月31日是无效的。当一名选手正好到达2001年11月4日时,他就赢得了比赛。如果玩家移动到2001年11月4日之后,他就会输掉游戏。

    思路:知道是找规律但是没看出来,搜题解后发现原来月加日期是偶数则赢,奇数则输,但是9.30和11.30也是赢的。当然还有一种方式就是打表。

    AC Code:

    #include<iostream>
    using namespace std;
    int main(){
        int n,y,m,d;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>y>>m>>d;
            if(m==9&&d==30||m==11&&d==30) cout<<"YES"<<endl;
            else if((m+d)%2==0) cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
    }
  • 相关阅读:
    Java Bean validation specification...
    javascript压缩工具:YUI compressor
    CSS: Float a div on another div, Ex: Text caption on picture
    汉文博士 0.5.3.1944 测试版发布
    简单记事本程序java源码项目
    Windows计算机功能Java源码
    HighCharts 图表插件 自定义绑定 时间轴数据
    Windows Phone 8.1 新特性
    可自定义导航条功能案例ios项目源码
    自动计算尺寸列表功能案例ios源码
  • 原文地址:https://www.cnblogs.com/astonc/p/9949988.html
Copyright © 2011-2022 走看看