zoukankan      html  css  js  c++  java
  • poj1204之AC自动机

    Word Puzzles
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 8235   Accepted: 3104   Special Judge

    Description

    Word puzzles are usually simple and very entertaining for all ages. They are so entertaining that Pizza-Hut company started using table covers with word puzzles printed on them, possibly with the intent to minimise their client's perception of any possible delay in bringing them their order. 

    Even though word puzzles may be entertaining to solve by hand, they may become boring when they get very large. Computers do not yet get bored in solving tasks, therefore we thought you could devise a program to speedup (hopefully!) solution finding in such puzzles. 

    The following figure illustrates the PizzaHut puzzle. The names of the pizzas to be found in the puzzle are: MARGARITA, ALEMA, BARBECUE, TROPICAL, SUPREMA, LOUISIANA, CHEESEHAM, EUROPA, HAVAIANA, CAMPONESA. 

    Your task is to produce a program that given the word puzzle and words to be found in the puzzle, determines, for each word, the position of the first letter and its orientation in the puzzle. 

    You can assume that the left upper corner of the puzzle is the origin, (0,0). Furthemore, the orientation of the word is marked clockwise starting with letter A for north (note: there are 8 possible directions in total). 

    Input

    The first line of input consists of three positive numbers, the number of lines, 0 < L <= 1000, the number of columns, 0 < C <= 1000, and the number of words to be found, 0 < W <= 1000. The following L input lines, each one of size C characters, contain the word puzzle. Then at last the W words are input one per line.

    Output

    Your program should output, for each word (using the same order as the words were input) a triplet defining the coordinates, line and column, where the first letter of the word appears, followed by a letter indicating the orientation of the word according to the rules define above. Each value in the triplet must be separated by one space only.

    Sample Input

    20 20 10
    QWSPILAATIRAGRAMYKEI
    AGTRCLQAXLPOIJLFVBUQ
    TQTKAZXVMRWALEMAPKCW
    LIEACNKAZXKPOTPIZCEO
    FGKLSTCBTROPICALBLBC
    JEWHJEEWSMLPOEKORORA
    LUPQWRNJOAAGJKMUSJAE
    KRQEIOLOAOQPRTVILCBZ
    QOPUCAJSPPOUTMTSLPSF
    LPOUYTRFGMMLKIUISXSW
    WAHCPOIYTGAKLMNAHBVA
    EIAKHPLBGSMCLOGNGJML
    LDTIKENVCSWQAZUAOEAL
    HOPLPGEJKMNUTIIORMNC
    LOIUFTGSQACAXMOPBEIO
    QOASDHOPEPNBUYUYOBXB
    IONIAELOJHSWASMOUTRK
    HPOIYTJPLNAQWDRIBITG
    LPOINUYMRTEMPTMLMNBO
    PAFCOPLHAVAIANALBPFS
    MARGARITA
    ALEMA
    BARBECUE
    TROPICAL
    SUPREMA
    LOUISIANA
    CHEESEHAM
    EUROPA
    HAVAIANA
    CAMPONESA

    Sample Output

    0 15 G
    2 11 C
    7 18 A
    4 8 C
    16 13 B
    4 15 E
    10 3 D
    5 1 E
    19 7 C
    11 11 H

    题意:输入n,m,w代表先给定n行m列字符,接下来w行每行给定一组字符串,求该字符串在n*m的矩阵中首先出现的起始位置,字符串可以和矩阵中以某点开始8个方向进行匹配

    输出首先匹配的起始点坐标和匹配的方向

    方向为A,B,C,D...

    分析:将w各字符串插入字典树,然后用n*m的矩阵去匹配,匹配方法是枚举8个方向去匹配

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<queue>
    #include<algorithm>
    #include<map>
    #include<iomanip>
    #define INF 99999999
    using namespace std;
    
    const int MAX=1000+10;
    char s[MAX][MAX],b[MAX];
    int n,m,w;
    int dir[8][2]={0,1,0,-1,1,0,-1,0,1,1,-1,-1,1,-1,-1,1};//八个方向
    char ch[9]="CGEADHFB";
    int pos[MAX][3];
    
    struct TrieNode{
    	int id;//记录第几个字符串 
    	TrieNode *next[26],*fail;
    	TrieNode(){
    		id=0;
    		fail=0;
    		memset(next,0,sizeof next);
    	}
    }*root;
    
    void InsertNode(char *a,int id){
    	int len=strlen(a)-1;
    	TrieNode *p=root;
    	while(len>=0){//这里将a数组倒着插入字典树,方便匹配时记录匹配的终点即原串的起始点
    		if(!p->next[a[len]-'A'])p->next[a[len]-'A']=new TrieNode;
    		p=p->next[a[len--]-'A'];
    	}
    	p->id=id;
    }
    
    void Build_AC(){
    	TrieNode *p=root,*next;
    	queue<TrieNode *>q;
    	q.push(root);
    	while(!q.empty()){
    		p=q.front();
    		q.pop();
    		for(int i=0;i<26;++i){
    			if(p->next[i]){
    				next=p->fail;
    				while(next && !next->next[i])next=next->fail;
    				if(next)p->next[i]->fail=next->next[i];
    				else p->next[i]->fail=root;
    				q.push(p->next[i]);
    			}
    		}
    	}
    }
    
    void SearchTrie(int x,int y,int d,int id){
    	TrieNode *p=root,*next; 
    	while(x>=0 && y>=0 && x<n && y<m){
    		while(p && !p->next[s[x][y]-'A'])p=p->fail;
    		if(!p)p=root;
    		else p=p->next[s[x][y]-'A'];
    		next=p;
    		while(next != root){
    			if(next->id){//记录原串被匹配的起始点
    				int k=next->id;
    				if(pos[k][0]>x || (pos[k][0] == x && pos[k][1]>y)){
    					pos[k][0]=x,pos[k][1]=y,pos[k][2]=id;
    				} 
    			} 
    			next=next->fail; 
    		}
    		x+=dir[d][0];
    		y+=dir[d][1];
    	}
    }
    
    void Free(TrieNode *p){
    	for(int i=0;i<26;++i)if(p->next[i])Free(p->next[i]);
    	delete p;
    }
    
    int main(){
    	while(cin>>n>>m>>w){
    		root=new TrieNode;
    		for(int i=0;i<n;++i)cin>>s[i];
    		for(int i=1;i<=w;++i){
    			cin>>b;
    			InsertNode(b,i);
    			pos[i][0]=pos[i][1]=INF;
    		}
    		Build_AC();
    		for(int i=0;i<n;++i){
    			SearchTrie(i,0,0,1),SearchTrie(i,m-1,1,0);//匹配左右方向
    			SearchTrie(i,0,7,6),SearchTrie(i,m-1,6,7);//匹配左上部分的右上角和右下部分左下角
    			SearchTrie(i,0,4,5),SearchTrie(i,m-1,5,4);//匹配左下部分右下角和右上部分左上角
    		}
    		for(int i=0;i<m;++i){
    			SearchTrie(0,i,2,3),SearchTrie(n-1,i,3,2);//匹配上下方向
    			SearchTrie(0,i,6,7),SearchTrie(n-1,i,7,6);//匹配左上部分左下角和右下部分右上角
    			SearchTrie(0,i,4,5),SearchTrie(n-1,i,5,4);//匹配右上部分的右下角和左下部分左上角 
    		}
    		for(int i=1;i<=w;++i)cout<<pos[i][0]<<' '<<pos[i][1]<<' '<<ch[pos[i][2]]<<endl;
    		Free(root);
    	}
    	return 0;
    }



  • 相关阅读:
    CCPC-Wannafly Winter Camp Day8 (Div2, onsite)
    Codeforces gym101612 E.Equal Numbers(贪心)
    Codeforces gym101612 L.Little Difference(枚举+二分)
    Linq-ToList与ToArray
    SQL SERVER性能分析
    无法访问IIS 没有足够的特权访问计算机
    SQL SERVER获得指定表的主键
    SQL Server 中master..spt_values的应用
    买了阿里云之后:挂载新硬盘
    支付宝WAP支付接口开发
  • 原文地址:https://www.cnblogs.com/aukle/p/3215123.html
Copyright © 2011-2022 走看看