zoukankan      html  css  js  c++  java
  • hdu find your present (2)

    find your present (2)

    Time Limit: 1000/2000 MS (Java/Others)    Memory Limit: 32768/1024 K (Java/Others)
    Total Submission(s): 2656    Accepted Submission(s): 811
     
    Problem Description
    In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
     
    Input
    The input file will consist of several cases. Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
     
    Output
    For each case, output an integer in a line, which is the card number of your present.
     
    Sample Input
    5
    1 1 3 2 2
    3
    1 2 1
    0
     
    Sample Output
    3
    2
    Hint
    Hint
    use scanf to avoid Time Limit Exceeded
     
    Author
    8600
     
    Source
    HDU 2007-Spring Programming Contest - Warm Up (1)
     
    Recommend
    8600

    分析:由于内存限制,这道题变成了水题中很有意思的智力题~使用位运算中的异或便可O(n)出答案

    #include<algorithm>
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    using namespace std;
    
    int main() {
        int n, ans, t;
        while (scanf("%d", &n) != EOF && n) {
            ans = 0;
            while (n--) {
                scanf("%d", &t);
                ans ^= t;
            }
            printf("%d\n", ans);
        }
        return 0;
    }
  • 相关阅读:
    智能车回忆
    自动化面试问题
    先进控制理论(转载)
    电力电子技术(转载)
    微型计算机原理及应用复习(转载)
    c语言中数值交换用值传递和地址传递
    unity调用苹果端方法
    unity调用安卓arr方法
    unity mono单例
    loading通用界面笔记
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2662805.html
Copyright © 2011-2022 走看看