zoukankan      html  css  js  c++  java
  • hdu Crixalis's Equipment

    Crixalis's Equipment

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1529    Accepted Submission(s): 471
     
    Problem Description
    Crixalis - Sand King used to be a  giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.
    Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
     
    Input
    The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi. 0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
     
    Output
    For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
     
    Sample Input
    2
    
    20 3
    10 20
    3 10
    1 7
    
    10 2
    1 10
    2 11
     
    Sample Output
    Yes
    No
     
     
    Source
    HDU 2009-10 Programming Contest
     
    Recommend
    lcy

    分析:贪心原则,先放入差最大的。

    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    using namespace std;
    
    typedef struct S {
        int need, act, cha;
    } GOOD;
    GOOD a[1010];
    
    bool cmp(GOOD x, GOOD y) {
        return x.cha > y.cha;
    }
    
    int main() {
        int T, V, n, i;
        scanf("%d", &T);
        while (T--) {
            scanf("%d%d", &V, &n);
            for (i = 0; i < n; ++i) {
                scanf("%d%d", &a[i].act, &a[i].need);
                a[i].cha = a[i].need - a[i].act;
            }
            sort(a, a + n, cmp);
            for (i = 0; i < n; ++i) {
                if (V >= a[i].need)
                    V -= a[i].act;
                else {
                    break;
                }
            }
            printf("%s\n", i == n ? "Yes" : "No");
        }
        return 0;
    }
  • 相关阅读:
    详细的描述一个测试活动完整的过程
    黑盒测试的测试用例常见设计方法都有哪些?请分别以具体的例子来说明这些方法在测试用例设计工作中的应用。
    测试计划工作的目的是什么?测试计划文档的内容应该包括什么?其中哪些是最重要的?
    redo log 有什么作用?
    Spring的简介和优点?
    java的语法基础(二)
    相对于Statement,PreparedStatement的优点是什么?
    MyBatis 的好处是什么?
    python中字符串的编码和解码
    相对于Statement,PreparedStatement的优点是什么?
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2662966.html
Copyright © 2011-2022 走看看