zoukankan      html  css  js  c++  java
  • hdu Buy the Ticket

    Buy the Ticket

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 785    Accepted Submission(s): 382
     
    Problem Description
    The \\\\\\\"Harry Potter and the Goblet of Fire\\\\\\\" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?
    Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).
    Now the problem for you is to calculate the number of different ways of the queue that the buying process won\\\\\\\'t be stopped from the first person till the last person. Note: initially the ticket-office has no money.
    The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.
     
    Input
    The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.
     
    Output
                For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.
     
    Sample Input
    3 0
    3 1
    3 3
    0 0
     
    Sample Output
    Test #1:
    6
    Test #2:
    18
    Test #3:
    180
     
    Author
    HUANG, Ninghai
     
     
    Recommend
    Eddy

    分析:卡特兰数+大数运算(大数*小数,大数/小数,阶乘,输出)。

    本题结论为:( C(m+n, n) - C(m+n, m+1) ) * m!* n! = (m+n)!* (m-n+1) / (m+1)

    推导:m个人拿50,n个人拿100

    1:    所以如果 n > m,那么排序方法数为 0 这一点很容易想清楚

    2:    现在我们假设 拿50的人用 ‘0’表示, 拿100的人用 1 表示。

          如果有这么一个序列
    0101101001001111.

          当第K个位置出现1的个数多余0的个数时就是一个不合法序列了

          假设m
    =4 n=3的一个序列是:0110100 显然,它不合法, 现在我们把它稍微变化一下:

          把第二个1(这个1前面的都是合法的)后面的所有位0变成1,1变成0

          就得到
    0111011 这个序列1的数量多于0的数量, 显然不合法, 但现在的关键不是看这个序列是不是合法的

          关键是:它和我们的不合法序列
    0110100 成一一对应的关系

          也就是说任意一个不合法序列(m个0,n个1), 都可以由另外一个序列(n
    -1个0和m+1个1)得到

          另外我们知道,一个序列要么是合法的,要么是不合法的

          所以,合法序列数量
    = 序列总数量 - 不合法序列的总量

          序列总数可以这样计算m
    +n 个位置中, 选择 n 个位置出来填上 1, 所以是 C(m+n, n)

          不合法序列的数量就是: m
    +n 个位置中, 选择 m+1 个位置出来填上 1 所以是 C(m+n, m+1)

          然后每个人都是不一样的,所以需要全排列 m
    !* n!
         
         所以最后的公式为 :  ( C(m+n, n) - C(m+n, m+1) ) * m!* n! 化简即 (m+n)!* (m-n+1) / (m+1)

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<string>
    using namespace std;
    #define MAX 100
    #define BASE 10000
    int fac[210][MAX];
    
    void mult(int a[], int b) {
        int i, temp = 0;
        for (i = MAX - 1; i >= 0; --i) {
            temp = b * a[i] + temp;
            a[i] = temp % BASE;
            temp = temp / BASE;
        }
    }
    
    void div(int a[], int b) {
        int i, temp = 0;
        for (i = 0; i < MAX; ++i) {
            temp = temp * BASE + a[i];
            a[i] = temp / b;
            temp = temp % b;
        }
    }
    
    void make_fact() {
        int i;
        fac[0][MAX - 1] = fac[1][MAX - 1] = 1;
        for (i = 2; i <= 200; ++i) {
            memcpy(fac[i], fac[i - 1], MAX * sizeof (int));
            mult(fac[i], i);
        }
    }
    
    void print(int a[]) {
        int i;
        for (i = 0; i < MAX; ++i) {
            if (a[i])
                break;
        }
        printf("%d", a[i++]);
        for (; i < MAX; ++i) {
            printf("%04d", a[i]);
        }
        printf("\n");
    }
    int ans[MAX];
    
    int main() {
        int m, n, t = 0;
        make_fact();
        while (scanf("%d%d", &m, &n) != EOF && (m || n)) {
            printf("Test #%d:\n", ++t);
            if (m < n) {
                printf("0\n");
                continue;
            }
            memcpy(ans, fac[m + n], MAX * sizeof (int));
            mult(ans, m - n + 1);
            div(ans, m + 1);
            print(ans);
        }
        return 0;
    }
  • 相关阅读:
    UE 不生成.bak文件
    DOTWeen 使用
    unity admob
    UGUI 判断元素进入舞台
    unity 解决ScrollRect嵌套滚动问题
    oc字符串与c字符串转换和拷贝
    Object-c中的单例
    JAVA比较两个List集合的方法
    CentOS 7 配置静态IP
    CentOS7安装Jdk1.8
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2664580.html
Copyright © 2011-2022 走看看