zoukankan      html  css  js  c++  java
  • hdu Watch The Movie

    Watch The Movie

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
    Total Submission(s): 245    Accepted Submission(s): 116
     
    Problem Description
    New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep. DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end. But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L. How clever you are! Please help DuoDuo’s uncle.
     
    Input
    The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case: The first line is: N(N <= 100),M(M<=N),L(L <= 1000) N: the number of DVD that DuoDuo want buy.  M: the number of DVD that the shop can sale. L: the longest time that her grandfather allowed to watch. The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
     
    Output
                Contain one number. (It is less then 2^31.) The total value that DuoDuo can get tonight. If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
     
    Sample Input
    1
    3 2 10
    11 100
    1 2
    9 1
     
    Sample Output
    3
     
     
    Source
    2010 ACM-ICPC Multi-University Training Contest(6)——Host by BIT
     
    Recommend
    zhouzeyong

    分析:0-1背包变形,选择物品数量一定,V可以不用完。

    #include<cstdio>
    #include<cstring>
    int w[110],v[110];
    int f[1010][110];
    int main()
    {
        int T,n,m,M,i,j,t;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d%d",&n,&m,&M);
            for(i=0;i<n;++i)
            {
                scanf("%d%d",&w[i],&v[i]);
            }
            for(i=0;i<=M;++i)
            {
                for(j=1;j<=m;++j)
                    f[i][j]=-2147483648;
                f[i][0]=0;
            }
    
            for(t=0;t<n;++t)
            {
                for(i=M;i>=w[t];--i)
                {
                    for(j=m;j>=1;--j)
                    {
                        if(f[i-w[t]][j-1]+v[t]>f[i][j])
                            f[i][j]=f[i-w[t]][j-1]+v[t];
                    }
                }
            }
            if(f[M][m]<0)
                printf("0\n");
            else
                printf("%d\n",f[M][m]);
        }
        return 0;
    }
  • 相关阅读:
    调试 Android* x86 应用程序的方法以及要使用的工具
    android 获取手机信息工具类
    Android 布局自适应屏幕
    php &amp; 和 &amp;amp; (主要是url 问题)
    系统的BIOS与系统安装
    ios的设计原则
    POJ 2409 Let it Bead(Polya简单应用)
    鸿学金信风控具体介绍
    Linux高性能server编程——I/O复用
    WCF问题集锦:未依照DataMember定义的名称序列化对象
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2664747.html
Copyright © 2011-2022 走看看