zoukankan      html  css  js  c++  java
  • hdu Dome of Circus

    Dome of Circus

    Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 283    Accepted Submission(s): 139
     
    Problem Description
    A travelling circus faces a tough challenge in designing the dome for its performances. The circus has a number of shows that happen above the stage in the air under the dome. Various rigs, supports, and anchors must be installed over the stage, but under the dome. The dome itself must rise above the center of the stage and has a conical shape. The space under the dome must be air-conditioned, so the goal is to design the dome that contains minimal volume. You are given a set of n points in the space; (xi, yi, zi) for 1 ≤ i ≤ n are the coordinates of the points in the air above the stage that must be covered by the dome. The ground is denoted by the plane z = 0, with positive z coordinates going up. The center of the stage is on the ground at the point (0, 0, 0). The tip of the dome must be located at some point with coordinates (0, 0, h) with h > 0. The dome must have a conical shape that touches the ground at the circle with the center in the point (0, 0, 0) and with the radius of r. The dome must contain or touch all the n given points. The dome must have the minimal volume, given the above constraints.
     
    Input
    The input begins with an integer T. The next T blocks each represents a case. The first line of each case contains a single integer number n (1 ≤ n ≤ 10 000) - the number of points under the dome. The following n lines describe points with three floating point numbers xi, yi, and zi per line - the coordinates of i-th point. All coordinates do not exceed 1000 by their absolute value and have at most 2 digits after decimal point. All zi are positive. There is at least one point with non-zero xi or yi.
     
    Output
    For each case , write to the output file a single line with two floating point numbers h and r - the height and the base radius of the dome. The numbers must be precise up to 3 digits after decimal point.
     
    Sample Input
    3
    1
    1.00 0.00 1.00
    2
    1.00 0.00 1.00
    0.00 1.50 0.50
    3
    1.00 0.00 1.00
    0.00 1.50 0.50
    -0.50 -0.50 1.00
     
    Sample Output
    3.000 1.500
    2.000 2.000
    2.000 2.000
     
    Author
    Georgiy Korneev
     
    Source
    2010 Northeastern European Regional Contest
     
    Recommend
    notonlysuccess
     

    分析:三分求最值。三分高,对于每个确定的高都有一个最小半径。

    #include<cstdio>
    #include<cmath>
    #define eps 1e-6
    int n;
    double x[10010], z[10010];
    
    double fun(double H) {
        int i;
        double r = 0;
        for (i = 0; i < n; ++i) {
            if (H * x[i] / (H - z[i]) > r)
                r = H * x[i] / (H - z[i]);
        }
        return r;
    }
    
    int main() {
        double a, b, c, d, t, r1, r2, temp;
        int T, i;
        scanf("%d", &T);
        while (T--) {
            a = 0;
            b = 1e9;
            scanf("%d", &n);
            for (i = 0; i < n; ++i) {
                scanf("%lf%lf%lf", &x[i], &t, &z[i]);
                x[i] = sqrt(x[i] * x[i] + t * t);
                if (z[i] > a)
                    a = z[i];
            }
            while (b - a > eps) {
                temp = (b - a) / 3;
                c = a + temp;
                d = b - temp;
                r1 = fun(c);
                r2 = fun(d);
                if (r1 * r1 * c < r2 * r2 * d)
                    b = d;
                else
                    a = c;
            }
            printf("%.3f %.3f\n", a, fun(a));
    
        }
        return 0;
    }
  • 相关阅读:
    防止论坛用户重复登录的方法 .
    配置Windows服务器支持json文件的方法
    在线修改ServU密码注意问题。
    a href=#与 a href=javascript:void(0) 的区别,以及location.href含义
    使用sql命令连接字符串类型和整型类型的数据
    数据库SQL Server 2005 的级联设置 外键赋值
    使用VS发布网站后遇到的Fill为Null的奇怪错误。
    使用Visual Studio 2005 IDE的宏,自动为c#变量生成属性
    推荐Zen Garden
    使用 aspnet_regsql.exe 向 SQL Express 数据库中注册脚本
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2666108.html
Copyright © 2011-2022 走看看