zoukankan      html  css  js  c++  java
  • hdu Strategic Game

    Strategic Game

    Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 58    Accepted Submission(s): 40
     
    Problem Description
    Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?
    Your program should find the minimum number of soldiers that Bob has to put for a given tree.
    The input file contains several data sets in text format. Each data set represents a tree with the following description:
    the number of nodes the description of each node in the following format node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier or node_identifier:(0)
    The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.
    For example for the tree:

    the solution is one soldier ( at the node 1).
    The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
     
     
     
    Sample Input
    4
    0:(1) 1
    1:(2) 2 3
    2:(0)
    3:(0)
    5
    3:(3) 1 4 2
    1:(1) 0
    2:(0)
    0:(0)
    4:(0)
     
    Sample Output
    1
    2
     
     
    Source
    Southeastern Europe 2000
     
    Recommend
    JGShining

    分析:最少点覆盖边=最大匹配

    #include<cstdio>
    #include<cstring>
    #define maxn 1510
    
    typedef struct S {
        int v;
        struct S *next;
    } NODE;
    NODE *node[maxn], temp[100 * maxn], *edge[maxn];
    int cnt;
    
    void add(int a, int b) {
        temp[cnt].v = b;
        temp[cnt].next = node[a];
        node[a] = &temp[cnt++];
    }
    int vis[maxn], match[maxn];
    
    int dfs(int a) {
        int b;
        edge[a] = node[a];
        for (; edge[a]; edge[a] = edge[a]->next) {
            b = edge[a]->v;
            if (vis[b])
                continue;
            vis[b] = 1;
            if (match[b] == -1 || dfs(match[b])) {
                match[b] = a;
                return 1;
            }
        }
        return 0;
    }
    
    int main() {
        int n, i, j, m, a, b, ans;
        while (scanf("%d", &n) != EOF) {
            for (i = 0; i < n; ++i)
                node[i] = NULL;
            ans = 0;
            cnt = 0;
            memset(match, -1, sizeof (match));
            for (i = 0; i < n; ++i) {
                scanf("%d:(%d)", &a, &m);
                while (m--) {
                    scanf("%d", &b);
                    add(a, b);
                    add(b, a);
                }
            }
            for (i = 0; i < n; ++i) {
                memset(vis, 0, sizeof (vis));
                if (dfs(i))
                    ++ans;
            }
            printf("%d\n", ans / 2);
        }
        return 0;
    }
    这条路我们走的太匆忙~拥抱着并不真实的欲望~
  • 相关阅读:
    eureka 注册中心(单机版)
    金蝶实际成本培训01
    查看WIN10内核
    金蝶K3 WISE 15.0 GUID
    win10卸载系统自带office365
    金蝶K3wise15.0BOM维护默认只能查看登录账户作为建立人的BOM清单
    阿里云邮箱代收邮件
    金蝶寄售业务流程
    转-商品流通企业代销商品核算方法
    转-ERP待检仓、代管仓、赠品仓
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2710061.html
Copyright © 2011-2022 走看看