zoukankan      html  css  js  c++  java
  • ZOJ Monthly, November 2012 G Gao The Sequence

    Gao The Sequence

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    You are given a sequence of integers, A1,A2,...,An. And you are allowed a manipulation on the sequence to transform the origin sequence into another sequenceB1,B2,...,Bn(Maybe the two sequences are same ). The manipulation is specified as the following three steps:

    1.Select an integer Ai and choose an arbitrary positive integer delta as you like.

    2.Select some integers Aj satisfying j < i, let's suppose the selected integers are Ak1,Ak2,...,Akt , then subtract an arbitrary positive integer Di from Aki (1 ≤ i ≤ t) as long as sum(Di) = delta.

    3.Subtract delta from Ai.

    The manipulation can be performed any times. Can you find a way to transform A1,A2,...,An to B1,B2,...,Bn ?

    Input

    The input consist of multiple cases. Cases are about 100 or so. For each case, the first line contains an integer N(1 ≤ N ≤ 10000) indicating the number of the sequence. Then followed by N lines, ith line contains two integers Ai and Bi (0 ≤ Bi ≤ Ai ≤ 4294967296).

    Output

    Output a single line per case. Print "YES" if there is a certain way to transform Sequence A into Sequence B. Print "NO" if not.

    Sample Input

    3
    3 2
    4 2
    5 2
    3
    2 0
    7 1
    3 1
    

    Sample Output

    YES
    NO
    

    分析:将原题转化为直接在差数组上操作。利用贪心的思路,若目前节余的值t+s[i-1]仍然<c[i],则NO。一直没有NO就是YES。

    #include<cstdio>
    #include<cstring>
    typedef long long u64;
    u64 a[10010], b[10010], c[10010], s[10010], t;
    int n;
    
    int main() {
        int i;
        while (scanf("%d", &n) != EOF) {
            s[0] = 0;
            t = 0;
            for (i = 1; i <= n; ++i) {
                scanf("%lld%lld", &a[i], &b[i]);
                c[i] = a[i] - b[i];
                s[i] = s[i - 1] + c[i];
            }
            if (s[n]&1) {
                printf("NO\n");
                continue;
            }
            for (i = n; i >= 1; --i) {
                if (s[i - 1] + t < c[i]) {
                    printf("NO\n");
                    goto L;
                }
                if (s[i - 1] - c[i] <= t) {
                    break;
                }
                t += c[i];
            }
            printf("YES\n");
    L:
            ;
        }
        return 0;
    }
    这条路我们走的太匆忙~拥抱着并不真实的欲望~
  • 相关阅读:
    redis的发布订阅模式pubsub
    django集成celery之callback方式link_error和on_failure
    linux命令和awk
    使用beanstalkd实现定制化持续集成过程中pipeline
    JavaScript实现模糊推荐的input框(类似百度搜索框)
    hadoop streaming编程小demo(python版)
    一个scrapy框架的爬虫(爬取京东图书)
    mongodb生产环境(副本集模式)集群搭建配置
    TensorFlow加载图片的方法
    STC15W408AS简单使用教程-简单的光强检测!
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2796695.html
Copyright © 2011-2022 走看看