zoukankan      html  css  js  c++  java
  • 简单模拟与2993相反

    Your task is to read a picture of a chessboard position and print it in the chess notation.

    Input

    The input consists of an ASCII-art picture of a chessboard with chess pieces on positions described by the input. The pieces of the white player are shown in upper-case letters, while the black player's pieces are lower-case letters. The letters are one of "K" (King), "Q" (Queen), "R" (Rook), "B" (Bishop), "N" (Knight), or "P" (Pawn). The chessboard outline is made of plus ("+"), minus ("-"), and pipe ("|") characters. The black fields are filled with colons (":"), white fields with dots (".").

    Output

    The output consists of two lines. The first line consists of the string "White: ", followed by the description of positions of the pieces of the white player. The second line consists of the string "Black: ", followed by the description of positions of the pieces of the black player. 

    The description of the position of the pieces is a comma-separated list of terms describing the pieces of the appropriate player. The description of a piece consists of a single upper-case letter that denotes the type of the piece (except for pawns, for that this identifier is omitted). This letter is immediatelly followed by the position of the piece in the standard chess notation -- a lower-case letter between "a" and "h" that determines the column ("a" is the leftmost column in the input) and a single digit between 1 and 8 that determines the row (8 is the first row in the input). 

    The pieces in the description must appear in the following order: King("K"), Queens ("Q"), Rooks ("R"), Bishops ("B"), Knights ("N"), and pawns. Note that the numbers of pieces may differ from the initial position because of capturing the pieces and the promotions of pawns. In case two pieces of the same type appear in the input, the piece with the smaller row number must be described before the other one if the pieces are white, and the one with the larger row number must be described first if the pieces are black. If two pieces of the same type appear in the same row, the one with the smaller column letter must appear first.

    Sample Input

    +---+---+---+---+---+---+---+---+
    |.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
    +---+---+---+---+---+---+---+---+
    |:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
    +---+---+---+---+---+---+---+---+
    |...|:::|.n.|:::|...|:::|...|:p:|
    +---+---+---+---+---+---+---+---+
    |:::|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |...|:::|...|:::|.P.|:::|...|:::|
    +---+---+---+---+---+---+---+---+
    |:P:|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
    +---+---+---+---+---+---+---+---+
    |:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
    +---+---+---+---+---+---+---+---+
    

    Sample Output

    White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
    Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6
    #include <iostream>
    #include <vector>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include<algorithm>
    #include<string>
    using namespace std;
     
    const int maxn = 9;
     
    int getid[150];
     
    struct Piece
    {
        int x, y, d;
        Piece()
        {
        }
        Piece(int xx, int yy, char dd) :
            x(xx), y(yy), d(dd)
        {
        }
    };
     
    vector<vector<Piece> > piece(12);
     
    void init()
    {
        string st;
     
        memset(getid, -1, sizeof(getid));
        getid[int('K')] = 0;
        getid[int('Q')] = 1;
        getid[int('R')] = 2;
        getid[int('B')] = 3;
        getid[int('N')] = 4;
        getid[int('P')] = 5;
        getid[int('k')] = 6;
        getid[int('q')] = 7;
        getid[int('r')] = 8;
        getid[int('b')] = 9;
        getid[int('n')] = 10;
        getid[int('p')] = 11;
        for (int i = 1; i < maxn; i++)
        {
            getline(cin, st);
            for (int j = 1; j < maxn; j++)
            {
                char ch;
                getchar();
                getchar();
                cin >> ch;
                getchar();
                if (getid[int(ch)] != -1)
                    piece[getid[int(ch)]].push_back(Piece(9 - i, j, ch));
            }
            getline(cin, st);
        }
    }
     
    bool cmpWhite(const Piece &a, const Piece &b)
    {
        if (a.x == b.x)
            return a.y < b.y;
        return a.x < b.x;
    }
     
    bool cmpBlack(const Piece &a, const Piece &b)
    {
        if (a.x == b.x)
            return a.y < b.y;
        return a.x > b.x;
    }
     
    void sortout()
    {
        for (int i = 0; i < 6; i++)
            sort(piece[i].begin(), piece[i].end(), cmpWhite);
        for (int i = 6; i < 12; i++)
            sort(piece[i].begin(), piece[i].end(), cmpBlack);
    }
     
    void output()
    {
        bool first = true;
     
        cout << "White: ";
        for (int i = 0; i < 6; i++)
        {
            for (unsigned int j = 0; j < piece[i].size(); j++)
            {
                if (first)
                    first = false;
                else
                    cout << ",";
                if (piece[i][j].d != 'P')
                    cout << char(piece[i][j].d);
                cout << char(piece[i][j].y + 'a' - 1) << piece[i][j].x;
            }
        }
     
        cout << endl;
        first = true;
        cout << "Black: ";
        for (int i = 6; i < 12; i++)
        {
            for (unsigned int j = 0; j < piece[i].size(); j++)
            {
                if (first)
                    first = false;
                else
                    cout << ",";
                if (piece[i][j].d != 'p')
                    cout << char(piece[i][j].d - 'a' + 'A');
                cout << char(piece[i][j].y + 'a' - 1) << piece[i][j].x;
            }
        }
    }
     
    int main()
    {
        //freopen("D:\t.txt", "r", stdin);
        init();
        sortout();
        output();
        return 0;
    }
  • 相关阅读:
    moment.js常用时间示例,时间管理
    RabbitMQ用户增删及权限控制
    CDN概念基本介绍
    在LinkedIn的 Kafka 生态系统
    发行说明
    Kafka 1.0版本发布
    redis应用场景及实例
    Redis哨兵集群
    redis-订阅与发布
    redis事务
  • 原文地址:https://www.cnblogs.com/baoluqi/p/3745494.html
Copyright © 2011-2022 走看看