zoukankan      html  css  js  c++  java
  • 数制形式转换问题

    问题:When a number is expressed in decimal, the kth digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example,
    81307(10) = 8 * 10^4 + 1 * 10 ^3 + 3 * 10^2 + 0 * 10^1 + 7 * 10^0
    = 80000 + 1000 + 300 + 0 + 7
    = 81307.

    When a number is expressed in binary, the kth digit represents a multiple of 2^k . For example,

    10011(2) = 1 * 2^4 + 0 * 2^3 + 0 * 2^2 + 1 * 2^1 + 1 * 2^0
    = 16 + 0 + 0 + 2 + 1
    = 19.

    In skew binary, the kth digit represents a multiple of 2^(k+1)-1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example,

    10120(skew) = 1 * (2^5-1) + 0 * (2^4-1) + 1 * (2^3-1) + 2 * (2^2-1) + 0 * (2^1-1)
    = 31 + 0 + 7 + 6 + 0
    = 44.

    The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.)

    Sample Input
    10120
    200000000000000000000000000000
    10
    1000000000000000000000000000000
    11
    100
    11111000001110000101101102000
    0

    Sample Output
    44
    2147483646
    3
    2147483647
    4
    7
    1041110737

    回答:主要是pow函数使用。

    #include <iostream>  
    #include <string>  
    #include <cmath>  
    using namespace std;  
    int main(){  
        string s;  
        while(1){  
            cin>>s;  
            if (s == "0")  
                break;  
            long result = 0;  
            int k = 1;  
            string::iterator it;  
            for (it = s.end()-1;it!=s.begin();it--)  
            {  
                result += (*it - '0')*(pow(double(2),k++) - 1);  
            }  
            result += (*it - '0')*(pow(double(2),k) - 1);  
            cout<<result<<endl;  
        }  
        return 0;  
    }

  • 相关阅读:
    装饰器和表达生成式
    函数
    字符编码
    函数基础
    列表,字典与集合
    Linux Semaphore
    tp5安装easyWeChat
    wx.request
    小程序设计规范
    小程序的概念和特点
  • 原文地址:https://www.cnblogs.com/benchao/p/4500005.html
Copyright © 2011-2022 走看看