zoukankan      html  css  js  c++  java
  • 左偏树(DP)问题

    问题:A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

    You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

        |A1 - B1| + |A2 - B2| + ... + |AN - BN |

    Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

    Input
    * Line 1: A single integer: N
    * Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

    Output
    * Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

    Sample Input
    7
    1
    3
    2
    4
    5
    3
    9

    Sample Output
    3

    回答:题意给定一个序列,以最小代价将其变成单调不增或单调不减序列。

    #include "stdio.h"
    #include "iostream"
    #include "algorithm"
    using namespace std;

    __int64 dp[2][2003];

    int main()
    {
        freopen("aaa.txt","r",stdin);
        __int64 m,temp;
        __int64 a[2003],b[2003];
        int n,i,j;

        while(scanf("%d",&n)!=EOF)
        {
            for(i=1; i<=n; i++)
                scanf("%I64d",&a[i]), b[i]=a[i];
            sort(b+1,b+n+1);
            for(i=1; i<=n; i++)
            {
                dp[1][i] = a[1]-b[i];
                if(dp[1][i]<0)  dp[1][i]=-dp[1][i];
            }

            for(i=2; i<=n; i++)
            {
                temp=dp[(i+1)%2][1];
                for(j=1; j<=n; j++)
                {
                    temp=min(temp,dp[(i+1)%2][j]);
                    m=a[i]-b[j];
                    if(m<0)  m=-m;
                    dp[i%2][j]=temp+m;
                }
            }
            temp=dp[n%2][n];
            for(i=n; i>=1; i--)
                temp = min(temp,dp[n%2][i]);
            printf("%I64d ",temp);
        }
        return 0;
    }

  • 相关阅读:
    Android 自定义 ListView 上下拉动刷新最新和加载更多
    Android Activity 及其子类
    MySQL INSERT插入条件判断:如果不存在则插入
    MySQL中函数CONCAT及GROUP_CONCAT
    数据权限的设计与实现
    shiro过滤器过滤属性含义
    shiro注解
    python中,花括号,中括号,小括号的区别
    SpringBoot项目eclipse运行正常maven install打包启动后报错ClassNotFoundException
    Nginx对某个目录或整个网站进行登录认证的方法
  • 原文地址:https://www.cnblogs.com/benchao/p/4565325.html
Copyright © 2011-2022 走看看