zoukankan      html  css  js  c++  java
  • 简单博弈问题

    问题:Alice and Bob are playing a kind of special game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with one in each grid and every coin may be upward or downward freely. Then they take turns to choose a rectangle (x1, y1)-(n, m) (1 ≤ x1≤n, 1≤y1≤m) and flips all the coins (upward to downward, downward to upward) in it (i.e. flip all positions (x, y) where x1≤x≤n, y1≤y≤m)). The only restriction is that the top-left corner (i.e. (x1, y1)) must be changing from upward to downward. The game ends when all coins are downward, and the one who cannot play in his (her) turns loses the game. Here's the problem: Who will win the game if both use the best strategy? You can assume that Alice always goes first.
     
    Input
    The first line of the date is an integer T, which is the number of the text cases.
    Then T cases follow, each case starts with two integers N and M indicate the size of the board. Then goes N line, each line with M integers shows the state of each coin, 1<=N,M<=100. 0 means that this coin is downward in the initial, 1 means that this coin is upward in the initial.
     
    Output
    For each case, output the winner’s name, either Alice or Bob.
     
    Sample Input
    2
    2 2
    1 1
    1 1
    3 3
    0 0 0
    0 0 0
    0 0 0

    Sample Output
    Alice
    Bob

    回答:题目大意是说你每次可以选择一个硬币为正面的点(正面为1,反面为0),然后从该点与右下角点形成的矩阵硬币全都反向,直到一个人没有硬币可以选择则输。

    #include <cstdio>  
    #include <cstring>  
    #include <algorithm>  
    #include <iostream>  
    #include <vector>  
    using namespace std;  
     
    const int V = 1000 + 50;  
    const int MaxN = 80 + 5;  
    const int mod = 10000 + 7;  
    int T, n, m;  
    int main() {  
        int i, j;  
        scanf("%d", &T);  
        while(T--) {  
            int temp;  
            scanf("%d%d", &n, &m);  
            for(i = 0; i < n; ++i)  
                for(j = 0; j < m; ++j)  
                    scanf("%d", &temp);  
            if(temp == 1)  
                printf("Alice ");  
            else  
                printf("Bob ");  
        }  
    }

  • 相关阅读:
    [][]
    Spark笔记04
    Spark笔记03
    Spark笔记02
    Spark笔记01
    【熟能生巧】使用Screw快速生成数据库文档
    记一次关于jdbcTemplate.queryForList快速Debug及感悟
    【从零单排】Exception实战总结1
    【从零单排】Java性能排查实战模拟
    【从零单排】关于泛型Generic的一些思考
  • 原文地址:https://www.cnblogs.com/benchao/p/4569511.html
Copyright © 2011-2022 走看看