zoukankan      html  css  js  c++  java
  • 简单博弈问题

    问题:Alice and Bob are playing a kind of special game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with one in each grid and every coin may be upward or downward freely. Then they take turns to choose a rectangle (x1, y1)-(n, m) (1 ≤ x1≤n, 1≤y1≤m) and flips all the coins (upward to downward, downward to upward) in it (i.e. flip all positions (x, y) where x1≤x≤n, y1≤y≤m)). The only restriction is that the top-left corner (i.e. (x1, y1)) must be changing from upward to downward. The game ends when all coins are downward, and the one who cannot play in his (her) turns loses the game. Here's the problem: Who will win the game if both use the best strategy? You can assume that Alice always goes first.
     
    Input
    The first line of the date is an integer T, which is the number of the text cases.
    Then T cases follow, each case starts with two integers N and M indicate the size of the board. Then goes N line, each line with M integers shows the state of each coin, 1<=N,M<=100. 0 means that this coin is downward in the initial, 1 means that this coin is upward in the initial.
     
    Output
    For each case, output the winner’s name, either Alice or Bob.
     
    Sample Input
    2
    2 2
    1 1
    1 1
    3 3
    0 0 0
    0 0 0
    0 0 0

    Sample Output
    Alice
    Bob

    回答:题目大意是说你每次可以选择一个硬币为正面的点(正面为1,反面为0),然后从该点与右下角点形成的矩阵硬币全都反向,直到一个人没有硬币可以选择则输。

    #include <cstdio>  
    #include <cstring>  
    #include <algorithm>  
    #include <iostream>  
    #include <vector>  
    using namespace std;  
     
    const int V = 1000 + 50;  
    const int MaxN = 80 + 5;  
    const int mod = 10000 + 7;  
    int T, n, m;  
    int main() {  
        int i, j;  
        scanf("%d", &T);  
        while(T--) {  
            int temp;  
            scanf("%d%d", &n, &m);  
            for(i = 0; i < n; ++i)  
                for(j = 0; j < m; ++j)  
                    scanf("%d", &temp);  
            if(temp == 1)  
                printf("Alice ");  
            else  
                printf("Bob ");  
        }  
    }

  • 相关阅读:
    什么是三元表达式,遇到三元表达式,你该如何去看代码执行的结果,下面的方法简单实用!!!
    遍历某一个标签中的内容;python+selenium定位到列表整体,使用for循环获取列表文本;可用于校验列表是否存在你需要的文本内容
    Selenium3+python3--如何定位鼠标悬停才显示的元素
    selenium中get_attribute的简单使用
    css层叠样式
    前端初识
    视图,触发器,事务,存储过程,内置函数,索引
    pymysql基本操作
    多态与绑定方法
    封装与组合
  • 原文地址:https://www.cnblogs.com/benchao/p/4569511.html
Copyright © 2011-2022 走看看