zoukankan      html  css  js  c++  java
  • 1036.old bill

    题目描述:

        Among grandfather's papers a bill was found.
        72 turkeys $_679_
        The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are illegible. What are the two faded digits and what was the price of one turkey?
        We want to write a program that solves a general version of the above problem.
        N turkeys $_XYZ_
        The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkeys is an integer number of dollars, and that all the
    turkeys cost the same price.
        Given N, X, Y, and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two faded digits and the maximum price per turkey for the turkeys.

    输入:

        The first line of the input file contains an integer N (0<N<100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y, and Z., separated by a space, of the original price $_XYZ_.

    输出:

        For each case, output the two faded digits and the maximum price per turkey for the turkeys.

    样例输入:
    72
    6 7 9
    5
    2 3 7
    78
    0 0 5
    样例输出:
    3 2 511
    9 5 18475
    0
    #include<iostream>
    using namespace std; //用一个数字把i,j记下来!!! 
    
    bool money(int n,int a,int b,int c,int d,int e)
    {
        int m=e+d*10+c*100+b*1000+a*10000;
        if(m%n==0) return true;
        else return false;
    }
    
    int price(int n,int a,int b,int c,int d,int e){
        int m=e+d*10+c*100+b*1000+a*10000;
        int p=m/n;
        return p;
    }
    
    int main(){
        int n,x,y,z,i,j,a,b;
        while(cin>>n){
            int flag=0,flag1=0;
            cin>>x>>y>>z;
            for(i=9;i>=0;i--)
            {
                for(j=9;j>=0;j--)
                {
                    if(money(n,i,x,y,z,j)==true){
                        a=i;
                        b=j;
                        flag=1;
                        flag1=1;break;
                    }
                    if(flag1==1) break;
                }
            }
             if(flag==1) cout<<a<<" "<<b<<" "<<price(n,a,x,y,z,b)<<endl;
              else cout<<"0"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    oracle-游标总结
    js动态获取下拉框的数据(搜索条件之间互相影响)
    poi实现excel数据导入到mysql数据库(加上excel的验证)
    windows10下ActiveMQ的安装和启动
    hexo发表博文
    前端Web安全介绍及规避。。。
    小程序:pages/index/index/出现脚本错误或未正确调用Page()
    初步了解产品经理(个人笔记)
    浏览器唤起APP的思路(本文转载)
    常见浏览器兼容性问题总结
  • 原文地址:https://www.cnblogs.com/bernieloveslife/p/9736509.html
Copyright © 2011-2022 走看看