zoukankan      html  css  js  c++  java
  • 1002.Grading

    题目描述:

        Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
        For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
        • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
        • If the difference exceeds T, the 3rd expert will give G3.
        • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
        • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
        • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

    输入:

        Each input file may contain more than one test case.
        Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

    输出:

        For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

    样例输入:
    20 2 15 13 10 18
    样例输出:
    14.0


    #include<iostream>
    #include<iomanip> //cout<<fixed<<setprecision(1)<<  !!!! 
    using namespace std;
    
    int cha(int x,int y){
        if(x>y) return x-y;
        else return y-x;
    }
    
    int maximum(int a,int b,int c)
    {
        if(a>b){
            if(a>c) return a;
            else return c;
        }
        else {
            if(b>c) return b;
            else return c;
        }
    }
    
    
    int main(){
        int p,t,g1,g2,g3,gj;
        double score;
        while(cin>>p>>t>>g1>>g2>>g3>>gj){
            if(cha(g1,g2)<=t) {
                score=(g1+g2)/2;
            }
            else if(cha(g1,g3)>t && cha(g2,g3)>t){
                score=gj;
            }
            else if(cha(g1,g3)<=t && cha(g2,g3)<=t){
                score=maximum(g1,g2,g3);
            }
            else if(cha(g1,g3)<cha(g2,g3)){
                score=(g1+g3)/2;
            }
            else score=(g2+g3)/2;
            cout<<fixed<<setprecision(1)<<score<<endl;
        }
        return 0;
    }
  • 相关阅读:
    性能卓越的js模板引擎--artTemplate
    AngularJS学习笔记之依赖注入
    高性能的JavaScript库---Lodash
    如何阅读一本书
    我为什么写博客
    [cocos2d-x]深入--几个代表性的类 (续)
    [cocos2d-x]深入--几个代表性的类
    [cocos2dx]2.2到3.1(3.0)升级帮助
    [cocos2dx]利用NDK崩溃日志查找BUG
    IT技术团队管理-总结
  • 原文地址:https://www.cnblogs.com/bernieloveslife/p/9736598.html
Copyright © 2011-2022 走看看