zoukankan      html  css  js  c++  java
  • hdu 1159 Common Subsequence (dp乞讨LCS)

    Common Subsequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 24489    Accepted Submission(s): 10823


    Problem Description
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
     

    Sample Input
    abcfbc abfcab programming contest abcd mnp
     

    Sample Output
    4 2 0
     
    #include<stdio.h>
    #include<string>
    #include<vector>
    #include<iostream>
    using namespace std;
    int main(int argc, char *argv[])
    {
        string a,b;
        while(cin>>a>>b)
        {
            vector<vector<int> > c;
            int x=a.size();
            int y=b.size();
            int SIZE=x>y?x:y;
            SIZE+=1;
            c.resize(SIZE);
            for(int i=0;i<SIZE;++i)
                c[i].resize(SIZE,0);
            for(int i=0;i<=x;++i)
                c[i][0]=0;
            for(int i=0;i<=y;++i)
                c[0][i]=0;
            for(int i=1;i<=x;++i)
                for(int j=1;j<=y;++j)
                {
                    if(a[i-1]==b[j-1])
                    {
                        c[i][j]=c[i-1][j-1]+1;
                    }
                    else
                    {
                        c[i][j]=c[i][j-1]>c[i-1][j]?c[i][j-1]:c[i-1][j];
                    }
                }
            cout<<c[x][y]<<endl;
    
        }
        return 0;
    }
    



    版权声明:本文博客原创文章。博客,未经同意,不得转载。

  • 相关阅读:
    常用命令之mongodb
    常用之juc
    常用命令
    WSL2错误Error 0x1bc解决
    sudo:Unable to stat '/etc/sudoers': Permission Denied 解决办法
    CPIO写入ROOTFS到磁盘分区
    getElementsByClassName
    PetaLinux通过fw_printenv访问u-boot中的环境变量
    1. 两数之和
    find xargs grep查找文件及文件内容
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/4657147.html
Copyright © 2011-2022 走看看