zoukankan      html  css  js  c++  java
  • poj 1573 Robot Motion

    Robot Motion
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 10280   Accepted: 5006

    Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

    N north (up the page) 
    S south (down the page) 
    E east (to the right on the page) 
    W west (to the left on the page) 

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

    Input

    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

    Output

    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

    Sample Input

    3 6 5
    NEESWE
    WWWESS
    SNWWWW
    4 5 1
    SESWE
    EESNW
    NWEEN
    EWSEN
    0 0 0

    Sample Output

    10 step(s) to exit
    3 step(s) before a loop of 8 step(s)
    
    
    #include<iostream>
    #include<cstring>
    #define M 12
    using namespace std;
    int main()
    {
        int n,m,t,i,j,ans,k,vis[M][M];
        char a[M][M];
        while(cin>>n>>m>>t,n&&m&&t)
        {
            for(i=1;i<=n;i++)
                for(j=1;j<=m;j++)
                cin>>a[i][j];
                i=1;
                ans=0;
                memset(vis,0,sizeof(vis));
    
                while(i>0&&i<=n&&t<=m&&t>0)
                {
                    k=0;
                    if(vis[i][t]>0)
                    {
                        k=1;
                    break;
                    }
                    ans++;
                    if(a[i][t]=='W')
                       {
                           vis[i][t]=ans;
                            t-=1;
                       }
                    else if(a[i][t]=='E')
                       {
                           vis[i][t]=ans;
                           t+=1;
                       }
                    else if(a[i][t]=='S')
                       {
                           vis[i][t]=ans;
                           i+=1;
                       }
                    else if(a[i][t]=='N')
                       {
                           vis[i][t]=ans;
                           i-=1;
    
                       }
    
                }
    
    
                if(k)
                {
                    vis[i][t]-=1;
                    ans-=vis[i][t];
                 cout<<vis[i][t]<<" step(s) before a loop of "<<ans<<" step(s)"<<endl;
                }
                else
                    cout<<ans<<" step(s) to exit"<<endl;
        }
    
    
    }
    


    版权声明:本文博主原创文章,博客,未经同意不得转载。

  • 相关阅读:
    Linux 设备驱动--- Poll 方法 --- Select【转】
    Linux 设备驱动--- 阻塞型字符设备驱动 --- O_NONBLOCK --- 非阻塞标志【转】
    一篇不错的v4l2入门文档【转】
    戴文的Linux内核专题:03 驱动程序【转】
    戴文的Linux内核专题:02 源代码【转】
    使用 Python 开始你的机器学习之旅【转】
    双缓冲(Double Buffer)原理和使用【转】
    内核中的内存申请:kmalloc、vmalloc、kzalloc、kcalloc、get_free_pages【转】
    几种常见的YUV格式--yuv422:yuv420【转】
    C程序编译过程浅析【转】
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/4889336.html
Copyright © 2011-2022 走看看