zoukankan      html  css  js  c++  java
  • J Dp

    <span style="color:#000099;">/*
    ___________________________________________________________________________________________
         author      :   Grant Yuan
         time        :   2014.7.18
         algorithm   :   最长上升子序列求和
         
    ———————————————————————————————————————————————————————————————————————————————————————————
         
    J - 简单dp 例题扩展
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 
    
    
    
    
    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
    Your task is to output the maximum value according to the given chessmen list. 
     
    Input
    Input contains multiple test cases. Each test case is described in a line as follow: 
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
    A test case starting with 0 terminates the input and this test case is not to be processed. 
     
    Output
    For each case, print the maximum according to rules, and one line one case. 
     
    Sample Input
     3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0 
     
    Sample Output
     4
    10
    3 
    */
    
    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<functional>
    #include<algorithm>
    using namespace std;
    
    int a[100005],n;
    int dp[100005];
    
    int main()
    {
        while(1){
          cin>>n;
          if(n==0)  break;
          for(int i=1;i<=n;i++)
          cin>>a[i];
    
          memset(dp,0,sizeof(dp));
          a[0]=0;
          for(int i=1;i<=n;i++){
              dp[i]=a[i];
              for(int j=1;j<i;j++){
              if(a[i]>a[j])
               dp[i]=max(dp[i],dp[j]+a[i]);}}
          int max=dp[1];
          for(int i=1;i<=n;i++)
            if(dp[i]>max)
               max=dp[i];
           cout<<max<<endl;
             }
         return 0;
    }
    </span>

  • 相关阅读:
    libmegjb.so加载问题调试和分析
    art虚拟机启动问题分析
    高通发布骁龙808六核/810八核64位芯片
    pivotx的entry和page内容里的日期格式修改
    dlmalloc(Android bionic C库的malloc实现)简介
    dojo分析之declare接口
    零基础搞懂智能机之手机参数怎么看
    Google one联合联发科,国内低端智能机方案怎么办?
    自己搭建云存储(WIFI路由器上接硬盘)
    数据结构目录(浙大)
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/5052266.html
Copyright © 2011-2022 走看看