zoukankan      html  css  js  c++  java
  • hdu 2052 Picture(java)

    问题:
    開始直接用输入的数作为宽和高,但实际上要多出两行边框,所以要加一个2。

    还有题目要求最后要输出一个空行没有注意到。


    Picture

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 19789    Accepted Submission(s): 10178


    Problem Description
    Give you the width and height of the rectangle,darw it.
     

    Input
    Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
     

    Output
    For each case,you should draw a rectangle with the width and height giving in the input.
    after each case, you should a blank line.
     

    Sample Input
    3 2
     

    Sample Output
    +---+ | | | | +---+


    代码:

    import java.util.*;
    
    public class Main{
    	public static void n1(int t){
    		String s="";
    		for(int i=1;i<=t;i++){
    			if(i==1||i==t)
    				s=s+"+";
    			else
    				s=s+"-";
    		}	
    		System.out.println(s);
    	}
    	public static void n2(int t){
    		String s="";
    		for(int i=1;i<=t;i++){
    			if(i==1||i==t)
    				s=s+"|";
    			else
    				s=s+" ";
    		}	
    		System.out.println(s);
    	}
    	public static void main(String[] args) {
    		Scanner cin=new Scanner(System.in);
    		while(cin.hasNext()){
    			int n=cin.nextInt();
    			int m=cin.nextInt();
    			int t=n+2;
    			for(int i=0;i<m+2;i++){
    				if(i==0||i==m+1)
    					n1(t);
    				else
    					n2(t);
    			}
    			System.out.println();
    		}
    	}
    }


  • 相关阅读:
    js正则表达式中的问号使用技巧总结
    380. Insert Delete GetRandom O(1)
    34. Find First and Last Position of Element in Sorted Array
    162. Find Peak Element
    220. Contains Duplicate III
    269. Alien Dictionary
    18. 4Sum
    15. 3Sum
    224. Basic Calculator
    227. Basic Calculator II
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/5367916.html
Copyright © 2011-2022 走看看