zoukankan      html  css  js  c++  java
  • HDU4772(杭州赛区)

    Zhuge Liang's Password

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1120    Accepted Submission(s): 768


    Problem Description
      In the ancient three kingdom period, Zhuge Liang was the most famous and smart military leader. His enemy was Sima Yi, the military leader of Kingdom Wei. Sima Yi always looked stupid when fighting against Zhuge Liang. But it was Sima Yi who laughed to the end. 
      Zhuge Liang had led his army across the mountain Qi to attack Kingdom Wei for six times, which all failed. Because of the long journey, the food supply was a big problem. Zhuge Liang invented a kind of bull-like or horse-like robot called "Wooden Bull & Floating Horse"(in abbreviation, WBFH) to carry food for the army. Every WBFH had a password lock. A WBFH would move if and only if the soldier entered the password. Zhuge Liang was always worrying about everything and always did trivial things by himself. Since Ma Su lost Jieting and was killed by him, he didn't trust anyone's IQ any more. He thought the soldiers might forget the password of WBFHs. So he made two password cards for each WBFH. If the soldier operating a WBFH forgot the password or got killed, the password still could be regained by those two password cards.
      Once, Sima Yi defeated Zhuge Liang again, and got many WBFHs in the battle field. But he didn't know the passwords. Ma Su's son betrayed Zhuge Liang and came to Sima Yi. He told Sima Yi the way to figure out the password by two cards.He said to Sima Yi: 
      "A password card is a square grid consisting of N×N cells.In each cell,there is a number. Two password cards are of the same size. If you overlap them, you get two numbers in each cell. Those two numbers in a cell may be the same or not the same. You can turn a card by 0 degree, 90 degrees, 180 degrees, or 270 degrees, and then overlap it on another. But flipping is not allowed. The maximum amount of cells which contains two equal numbers after overlapping, is the password. Please note that the two cards must be totally overlapped. You can't only overlap a part of them."
      Now you should find a way to figure out the password for each WBFH as quickly as possible.
     

    Input
      There are several test cases.
      In each test case:
      The first line contains a integer N, meaning that the password card is a N×N grid(0<N<=30).
      Then a N×N matrix follows ,describing a password card. Each element is an integer in a cell. 
      Then another N×N matrix follows, describing another password card. 
      Those integers are all no less than 0 and less than 300.
      The input ends with N = 0
     

    Output
      For each test case, print the password.
     

    Sample Input
    2 1 2 3 4 5 6 7 8 2 10 20 30 13 90 10 13 21 0
     

    Sample Output
    0 2
     

    Source

    2013 Asia Hangzhou Regional Contest

    题意:给你两个n*n的矩阵,随意翻转一个矩阵0,90,180,270度,与还有一个矩阵重叠。求重叠的最大数字是多少

    求出坐标变换公式即可c[i][j] = a[n-j][i],相当于每次将矩阵逆置一次

    #include <algorithm>
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    int a[35][35];
    int b[35][35];
    int c[35][35];
    int n,m;
    void fanzhuan()
    {
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
        {
            c[i][j] = a[n-j+1][i];
        }
          for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
            {
                a[i][j] = c[i][j];
            }
    
    }
    
    int main()
    {
    #ifdef xxz
        freopen("in.txt","r",stdin);
    #endif
    
    
        while(cin>>n && n)
        {
            for(int i = 1; i <= n; i++)
                for(int j = 1; j <= n; j++)
                cin>>a[i][j];
            for(int i = 1; i <= n; i++)
                for(int j = 1; j <= n; j++)
                cin>>b[i][j];
    
                int ans = 0;
                int cent = 0;
                for(int i = 0; i <4; i++)
                {
                    cent = 0;
                    for(int j = 1; j <= n; j++)
                    {
                        for(int k = 1; k <= n; k++)
                        {
                            if(a[j][k] == b[j][k])  cent++;
                        }
                    }
    
                    ans = max(cent,ans);
                    fanzhuan();
                }
                cout<<ans<<endl;
        }
    }


  • 相关阅读:
    【转】staruml用户手册目录【中文翻译版】
    [转]“菜”鸟理解.NET Framework(CLI,CLS,CTS,CLR,FCL,BCL)
    [转]程序员面试题精选100题(51)顺时针打印矩阵
    [转] 程序员面试题精选100题(35)找出两个链表的第一个公共结点
    [转] 深入探索.NET框架内部了解CLR如何创建运行时对象
    海量数据处理的几种方法总结 .
    分析函数总结
    PLSQL实现排序(冒泡、选择、快速)
    oracle 分析函数2
    创建表分区的总结
  • 原文地址:https://www.cnblogs.com/bhlsheji/p/5409022.html
Copyright © 2011-2022 走看看