zoukankan      html  css  js  c++  java
  • POJ-2287.Tian Ji -- The Horse Racing (贪心)

    Tian Ji -- The Horse Racing

    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 17662   Accepted: 5452

    Description

    Here is a famous story in Chinese history. 
    That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others. 

    Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser. 

    Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian. 

    Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match. 

    It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China? 

    Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching... 

    However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem. 

    In this problem, you are asked to write a program to solve this special case of matching problem.

    Input

    The input consists of up to 50 test cases. Each case starts with a positive integer n ( n<=1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian's horses. Then the next n integers on the third line are the speeds of the king's horses. The input ends with a line that has a single `0' after the last test case.

    Output

    For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

    Sample Input

    3
    92 83 71
    95 87 74
    2
    20 20
    20 20
    2
    20 19
    22 18
    0
    

    Sample Output

    200
    0
    0
    

    Source

     
    思路:孙膑说:“现在用您的下等马对付他们的上等马,用您的上等马对付他们的中等马,用您的中等马对付他们的下等马。
    #include <iostream>
    #include <string>
    #include <algorithm>
    using namespace std;
    
    const int maxn = 1000 + 5;
    int n, yy[maxn], zz[maxn];
    
    int main() {
        while(cin >> n && n) {
            for(int i = 0; i < n; i ++) {
                cin >> yy[i];
            }
            for(int i = 0; i < n; i ++) {
                cin >> zz[i];
            }
            sort(yy, yy + n);
            sort(zz, zz + n);
            int lowyy = 0, lowzz = 0, highyy = n - 1, highzz = n - 1, cnt1 = 0, cnt2 = 0;
            while(highyy >= lowyy) {
                if(yy[lowyy] > zz[lowzz]) {//打得过就赚大了
                    lowyy ++;
                    lowzz ++;
                    cnt1 ++;
                } else if(yy[lowyy] < zz[lowzz]) {//打不过就用最垃圾的打他最牛皮的
                    lowyy ++;
                    highzz --;
                    cnt2 ++;
                } else {//平局
                    if(yy[highyy] > zz[highzz]) {//平局就看我最牛皮的能不能打过你最牛皮的,打的过就让他们两个先打
                        highyy --;
                        highzz --;
                        cnt1 ++;
                    } else {//打不过就只能让我最垃圾的打你最牛批的
                        if(yy[lowyy] < zz[highzz]) cnt2 ++;
                        lowyy ++;//为什么不考虑两个最牛皮的能不能打平手?我的最牛皮的留着打你稍微弱一点的
                        highzz --;
                    }
                }
            }
            int ans = cnt1 - cnt2;
            cout << ans * 200<< endl;
            // cout << cnt1 << endl << cnt2 << endl;
        }
        return 0;
    }
  • 相关阅读:
    jquery学习
    java--MVC引入JUnit单元测试
    BAE引擎发布到外网
    ORACLE1.26 综合:游标和动态SQL
    ORACLE1.25 动态SQL
    ORACLE1.24 银行系统操作和游标
    ORACLE1.23 loop,whild.for循环
    ORACLE1.23 if case when
    ORACLE1.22 %type %rowtype
    ORACLE1.21 PLSQL 01
  • 原文地址:https://www.cnblogs.com/bianjunting/p/11172311.html
Copyright © 2011-2022 走看看