zoukankan      html  css  js  c++  java
  • poj1003 Hangover


    Input

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    Output

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

    Sample Input

    1.00
    3.71
    0.04
    5.19
    0.00
              

    Sample Output

    3 card(s)
    61 card(s)
    1 card(s)
    273 card(s)
    import java.util.*;   
    public class Main {   
        public static void main(String[] args) {   
            Scanner cin = new Scanner(System.in);   
            String str;   
            int maxCardNum = 0;   
            while(cin.hasNext())   
            {   
                str = cin.nextLine();   
                if(str.equals("0.00"))   
                    break;   
                float len = Float.valueOf(str).floatValue();   
                maxCardNum = getCardNum(len);   
                System.out.println(maxCardNum + " card(s)");   
            }   
      
        }   
           
        private static int getCardNum(float len)   
        {   
            float value = 0;   
            int index = 2;     
            while (value < len)   
            {   
                value += 1.0/index;   
                index++;   
            }   
                   
            return index-2;   
        }   
      
    }  
  • 相关阅读:
    CVE-2010-3333
    CVE-2010-2883
    谷歌不兼容showModalDialog()方法出现对话窗口解决方法
    asp.net中邮箱发送
    在c#中access2003和access2007连接字符串
    MVC连接Sql Server数据库出现的小问题
    使用360浏览器访问字体逆时针旋转90度的问题
    bootstrap与360浏览器不兼容问题
    委托的使用方法
    某集网将我的信息给了谁?还是不良卖家不想卖东西
  • 原文地址:https://www.cnblogs.com/bigjava/p/3930437.html
Copyright © 2011-2022 走看看