zoukankan      html  css  js  c++  java
  • 1043 Is It a Binary Search Tree (25 分)

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

    Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:

    7
    8 6 5 7 10 8 11
    

    Sample Output 1:

    YES
    5 7 6 8 11 10 8
    

    Sample Input 2:

    7
    8 10 11 8 6 7 5
    

    Sample Output 2:

    YES
    11 8 10 7 5 6 8
    

    Sample Input 3:

    7
    8 6 8 5 10 9 11
    

    Sample Output 3:

    NO
    




    分析:

      1.对输入的一段序列生成一棵二叉搜索树

      2.判断:

          a.此二叉树的先序遍历和输入的序列相等,则输出此二叉树的后序遍历序列

          b.在 a 不成立的情况下,求这棵二叉树的镜像先序遍历序列,若和输入的序列相等,则输出二叉树的镜像后序遍历序列

          c.以上都不成立时,输出 "NO"

    反反复复写完一个小时,调试用了一个小时半左右。
    #include <iostream>
    #include<string>
    #include<cstdio>
    #include<cstring>
    #include<vector>
    #include<algorithm>
    using namespace std;
    typedef struct tree
    {
        struct tree* rchile;
        struct tree* lchile;
        int key;
    }Tree;
    vector<int> ori, perorder, minperorder, postorder, minpostorder;
    void insert(int num,Tree* &root)
    {
        if (root == NULL)
        {
            root = new Tree;
            //Tree* root = (Tree *)malloc(sizeof(tree));
            root->key = num;
            root->lchile = NULL;
            root->rchile = NULL;
            return;
        }
        else
        {
            if (root->key > num)
                insert(num, root->lchile);
            else if (root->key <= num)
                insert(num, root->rchile);
        }
    }//创建二叉排序树
    void preorder(Tree* root)
    {
        if (root==NULL) return;
        perorder.push_back(root->key);
        preorder(root->lchile);
        preorder(root->rchile);
    }//先序遍历
    
    void minpereorder(Tree* root)
    {
        if (root == NULL) return;
        minperorder.push_back(root->key);
        minpereorder(root->rchile);
        minpereorder(root->lchile);
    }//镜像先序遍历
    void pstorder(Tree* root)
    {
        if (root == NULL) return;
        pstorder(root->lchile);
        pstorder(root->rchile);
        postorder.push_back(root->key);
    }//后序遍历
    void minptorder(Tree* root)
    {
        if (root == NULL) return;
        minptorder(root->rchile);
        minptorder(root->lchile);
        minpostorder.push_back(root->key);
    }//镜像后序遍历
    int main()
    {
        int n;
        Tree* root = NULL;
        cin >> n;
        for (int i = 0; i < n; i++)
        {
            int tem;
            cin >> tem;
            insert(tem,root);
            ori.push_back(tem);        
        }
        /*for (int i = 0; i < ori.size(); i++)
        {
            cout << ori[i] << ' '<<endl;
        }*/
        preorder(root);
        /*for (int i = 0; i < perorder.size(); i++)
        {
            cout << perorder[i] << ' ';
        }*/
        minpereorder(root);
        pstorder(root);
        minptorder(root);
    
        if (ori == perorder)
        {
            cout << "YES" << endl;
            for (int i = 0; i < postorder.size(); i++)
            {
                int num = 0;
                num++;
                cout << postorder[i];
                if (i != postorder.size() - 1)
                    cout << ' ';
            }
        }
        else if (ori == minperorder)
        {
            cout << "YES" << endl;
            for (int i = 0; i < minpostorder.size(); i++)
            {
                int num = 0;
                num++;
                cout << minpostorder[i];
                if (i != minpostorder.size() - 1)
                    cout << ' ';
            }
        }
        else
        {
            cout << "NO";
        }
        //system("pause");
        return 0;
    }
  • 相关阅读:
    2019年6月4号总结
    2019年5月21号总结
    2019年5月8号总结
    2019年5月6号总结
    2019年5月5号总结
    2019年4月18号总结
    java错误笔记之判断字符知否为空出错
    错误笔记:静态方法不能实例化,直接用类名.方法名调用
    Thymeleaf中"th:each""th:if"的用法解析
    @ResponseBody 表示返回的是josn
  • 原文地址:https://www.cnblogs.com/binanry/p/9997718.html
Copyright © 2011-2022 走看看