zoukankan      html  css  js  c++  java
  • POJ 2586 Y2K Accounting Bug(枚举大水题)

    Y2K Accounting Bug
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10674   Accepted: 5344

    Description

    Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
    All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

    Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

    Input

    Input is a sequence of lines, each containing two positive integers s and d.

    Output

    For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

    Sample Input

    59 237
    375 743
    200000 849694
    2500000 8000000
    

    Sample Output

    116
    28
    300612
    Deficit
    看了两遍。不知道题意是什么。。

    。。借鉴了一下:

    题意: 有一个公司因为某个病毒使公司赢亏数据丢失,但该公司每月的 赢亏是一个定数,要么一个月赢利s,要么一月亏d。

    如今ACM仅仅知道该公司每五个月有一个赢亏报表。并且每次报表赢利情况都为亏。

    在一年中这种报表总共同拥有8次(1到5,2到6,…,8到12),如今要编一个程序确定当赢s和亏d给出。并满足每张报表为亏的情况下,全年公司最高可赢利多少,若存在。则输出多多额,若不存在,输出"Deficit"。


    分析:
    在保证连续5个月都亏损的前提下。使得每5个月中亏损的月数最少。

                  x=1:  ssssd,ssssd,ss    d>4s     赢利10个月  10s-2d
                  x=2:  sssdd,sssdd,ss    2d>3s    赢利8个月     8s-4d
                  x=3:  ssddd,ssddd,ss    3d>2s    赢利6个月     6s-6d 
                  x=4:  sdddd,sdddd,sd    4d>s     赢利3个月     3s-9d
                  x=5:  ddddd,ddddd,dd    4d<s     无赢利
    除了分类,枚举也能够,12个月。每一个月两种情况。。

    O(2^12)

    代码例如以下:

    #include <iostream>
    using namespace std;
    
    int main()
    {
    	int s,d;
    	int res;
    	while(cin>>s && cin>>d)
    	{
    		if(d>4*s)res=10*s-2*d;
    		else if(2*d>3*s)res=8*s-4*d;
    		else if(3*d>2*s)res=6*(s-d);
    		else if(4*d>s)res=3*(s-3*d);
    		else res=-1;
    		if(res<0)cout<<"Deficit"<<endl;
    		else cout<<res<<endl;
    	}
    	return 0;
    }

  • 相关阅读:
    AutoMapper在ABP框架
    Github for Windows使用介绍
    Net中的反应式编程
    webstorm创建nodejs + express + jade 的web 项目
    Nancy 框架
    Quartz.NET 任务调度框架
    从电商秒杀与抢购谈Web系统大规模并发
    SVN中tag branch trunk用法详解
    Hsql中In没有1000的限制
    Gradle sourceCompatibility has no effect to subprojects(转)
  • 原文地址:https://www.cnblogs.com/blfbuaa/p/6812494.html
Copyright © 2011-2022 走看看