zoukankan      html  css  js  c++  java
  • 1029. Median (25)

    主题如以下:

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output

    For each test case you should output the median of the two given sequences in a line.

    Sample Input
    4 11 12 13 14
    5 9 10 15 16 17
    
    Sample Output
    13
    

    题目很easy。仅仅须要输出两个集合并集的中位数(索引取下整),我的解决的方法是把全部元素压入vector,然后调用sort函数得到非降序,(vector容量-1)/2 这个索引相应的就是要找的中位数。

    #include <iostream>
    #include <vector>
    #include <algorithm>
    #include <stdio.h>
    
    using namespace std;
    
    int main()
    {
        vector<long int> setA;
        int N;
        cin >> N;
        long int value;
        for(int i = 0; i < N; i++){
            scanf("%ld",&value);
            setA.push_back(value);
        }
        cin >> N;
            for(int i = 0; i < N; i++){
            scanf("%ld",&value);
            setA.push_back(value);
        }
        sort(setA.begin(),setA.end());
        cout << setA[(setA.size() - 1)/2] << endl;
        return 0;
    }
    




    版权声明:本文博主原创文章。博客,未经同意不得转载。

  • 相关阅读:
    GoldenGate 19.1实时文本文件加载攻略
    windows 10 excel 打开超连接提示 组织策略阻止...
    验证ogg同步数据库表无主键表且目标表包含隐藏字段
    配置ogg从Oracle到PostgreSQL的同步复制json数据
    pi
    GoldenGate 19.1 发布
    ogg同步DDL时,源和目标端表空间名称不同的解决思路
    总目录索引(开发精华总结)
    Spring Cloud Nacos分布式配置中心
    Spring Cloud Nacos&Feign负载均衡
  • 原文地址:https://www.cnblogs.com/blfshiye/p/4942948.html
Copyright © 2011-2022 走看看