zoukankan      html  css  js  c++  java
  • poj 1611 The Suspects(并查集)

    The Suspects
    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 21598   Accepted: 10461

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    Source

    题目大意  :有n个学生   m个小组,每小组有k个学生,一个学生可能会參加多个小组。小组中仅仅要有一个人得病,其余的都是嫌疑人。如今已知这些小组的人员,且0号学生已经患病。求一共同拥有多少个嫌疑人

    并查集的基本运用 

    每一个小组的人员属于同一个集合。在根节点记录每一个集合的个数num[i],然后找到0所属的根节点。num[find_Set(0)]即为全部的嫌疑人数。

    #include <iostream>
    #include<cstdio>
    using namespace std;
    const int Max=300010;
    
    int p[Max],rank[Max];
    int num[Max];//元素个数
    
    int Find_Set(int x)
    {
    	if (x!=p[x])
    		p[x]=Find_Set(p[x]);
    	return p[x];
    }
    
    void Union(int x,int y)
    {
    	x=Find_Set(x);
    	y=Find_Set(y);
    	if(x==y)
    		return;
    	if (rank[x]>rank[y])
    	{
    		p[y]=x;
    		num[x]+=num[y];
    	}
    	else
    	{
    		p[x]=y;
    		if (rank[x]==rank[y])
    			rank[x]++;
    		num[y]+=num[x];
    	}
    }
    
    int main()
    {
    	int i,j,k,n,m;
    	int a,b;
    	int s1,s2;
    	while (cin>>n>>m)
    	{
    	    if(n==0&&m==0)
    	    {
    	        break;
    	    }
    		for (i=0;i<n;i++)
    		{
    			p[i]=i;
    			rank[i]=0;
    			num[i]=1;
    		}
    		for (i=0;i<m;i++)
    		{
    			cin>>k>>a;
    			for (j=1;j<k;j++)
    			{
    				cin>>b;
    				s1=Find_Set(a);
    				s2=Find_Set(b);
    				Union(s1,s2);
    			}
    		}
    		i=Find_Set(0);
    		cout<<num[i]<<endl;
    	}
    	return 0;
    }
    
       
    
  • 相关阅读:
    百度地图API显示多个标注点带百度样式信息检索窗口的代码
    百度地图API显示多个标注点并添加百度样式检索窗口
    log4j.xml 为什么要使用SLF4J而不是Log4J
    C++编程学习52个经典网站 强力推荐
    一些User-Agent
    outlook 2003配置连接exchange server 2010报错——无法完成此操作。 与 Microsoft Exchange Server 的连接不可用。 Outlook 必须联机或连接才可完成该操作
    postfix+dovecot邮箱服务器
    Java学习之InputStream中read()与read(byte[] b)
    Java Scoket之java.io.EOFException解决方案
    java.util.zip.GZIPInputStream.readUByte,Not in GZIP format错误处理
  • 原文地址:https://www.cnblogs.com/blfshiye/p/5054986.html
Copyright © 2011-2022 走看看