zoukankan      html  css  js  c++  java
  • poj1573&&hdu1035 Robot Motion(模拟)

    转载请注明出处:http://blog.csdn.net/u012860063?

    viewmode=contents

    题目链接:

    HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1035

    POJ:   http://poj.org/problem?

    id=1573

    
    

    Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

    N north (up the page) 
    S south (down the page) 
    E east (to the right on the page) 
    W west (to the left on the page) 

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

    Input

    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

    Output

    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

    Sample Input

    3 6 5
    NEESWE
    WWWESS
    SNWWWW
    4 5 1
    SESWE
    EESNW
    NWEEN
    EWSEN
    0 0 0

    Sample Output

    10 step(s) to exit
    3 step(s) before a loop of 8 step(s)

    纯模拟题;

    代码例如以下:

    #include <iostream>
    using namespace std;
    #include <cstring>
    #define M 1000
    char mat[M][M];
    int re[M][M];
    int n, m, s;
    int ans, i, j, k;
    void F()
    {	
    	i = 1; j = s;
    	k = 0;
    	for(int l = 1; ; l++)
    	{
    		if(re[i][j] != 0)
    		{
    			ans = k - re[i][j];
    			break;
    		}
    		if(i>n || i<1 || j>m || j<1)
    		{
    			break;
    		}
    		if(mat[i][j] == 'N')
    		{
    			k++;
    			re[i][j] = k;
    			i-=1;
    			continue;
    		}
    		if(mat[i][j] == 'S')
    		{
    			k++;
    			re[i][j] = k;
    			i+=1;
    			
    			continue;
    		}
    		if(mat[i][j] == 'W')
    		{
    			k++;
    			re[i][j] = k;
    			j-=1;
    			continue;
    		}
    		if(mat[i][j] == 'E')
    		{
    			k++;
    			re[i][j] = k;
    			j+=1;
    			continue;
    		}
    	}
    }
    int main()
    {
    	while(cin>>n>>m>>s)
    	{
    		ans = 0;
    		if(n == 0 && m == 0 && s == 0)
    		break;
    		memset(mat,0,sizeof(mat));
    		memset(re,0,sizeof(re));
    		for(i = 1; i <= n; i++)
    		{
    			for(j = 1; j <= m; j++)
    			{
    				cin>>mat[i][j];
    			}
    		}
    		F();
    		if(ans == 0)
    		cout<<k<<" step(s) to exit"<<endl;
    		else
    		cout<<re[i][j]-1<<" step(s) before a loop of "<<ans+1<<" step(s)"<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    【BZOJ1452】【JSOI2009】count
    【BZOJ1030】【JSOI2007】文本生成器
    【BZOJ2427】【HAOI2010】软件安装
    从【BZOJ4173】谈做题技巧
    小A的旅行(绿豆蛙的归宿)【期望DP】
    甜点 【多重背包】
    洛谷 [P1154] 奶牛分厩
    POJ [P2631] Roads in the North
    洛谷 [P3258] 松鼠的新家
    洛谷 [P3398] 仓鼠找sugar
  • 原文地址:https://www.cnblogs.com/blfshiye/p/5097723.html
Copyright © 2011-2022 走看看