zoukankan      html  css  js  c++  java
  • Luogu P1550 打井Watering Hole

    P1550 [USACO08OCT]打井Watering Hole

    题目背景

    John的农场缺水了!!!

    题目描述

    Farmer John has decided to bring water to his N (1 <= N <= 300) pastures which are conveniently numbered 1..N. He may bring water to a pasture either by building a well in that pasture or connecting the pasture via a pipe to another pasture which already has water.

    Digging a well in pasture i costs W_i (1 <= W_i <= 100,000).

    Connecting pastures i and j with a pipe costs P_ij (1 <= P_ij <= 100,000; P_ij = P_ji; P_ii=0).

    Determine the minimum amount Farmer John will have to pay to water all of his pastures.

    POINTS: 400

    农民John 决定将水引入到他的n(1<=n<=300)个牧场。他准备通过挖若

    干井,并在各块田中修筑水道来连通各块田地以供水。在第i 号田中挖一口井需要花费W_i(1<=W_i<=100,000)元。连接i 号田与j 号田需要P_ij (1 <= P_ij <= 100,000 , P_ji=P_ij)元。

    请求出农民John 需要为连通整个牧场的每一块田地所需要的钱数。

    输入输出格式

    输入格式:

    第1 行为一个整数n。

    第2 到n+1 行每行一个整数,从上到下分别为W_1 到W_n。

    第n+2 到2n+1 行为一个矩阵,表示需要的经费(P_ij)。

    输出格式:

    只有一行,为一个整数,表示所需要的钱数。

    输入输出样例

    输入样例#1:
    4
    5
    4
    4
    3
    0 2 2 2
    2 0 3 3
    2 3 0 4
    2 3 4 0
    

      

    输出样例#1:
    9<br>
    

      

    说明

    John等着用水,你只有1s时间!!!


    好吧,原谅我太弱了,我也是看的题解,直接被泥萌的脑洞给吓着了。

    $$%%%$$

    居然是把打井的点看做是与农夫山泉农夫三拳连起来,就是和0号节点连边,然后直接就是最小生成树的模板题了。

    脑洞脑洞

    上代码

    #include <algorithm>
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    
    using namespace std;
    
    int n, xxx, cnt, ans, tot, f[307];
    
    bool vis[307][307];
    
    struct edge{int u, v, w;}ed[301*301];
    
    int find(int x) {
    	if(f[x] == x) return x;
    	else return f[x] = find(f[x]);
    }
    
    bool cmp(edge a, edge b) {
    	return a.w < b.w;
    }
    
    int main() {
    	scanf("%d", &n);
    	for(int i=1; i<=n; i++) {scanf("%d", &ed[++cnt].w); ed[cnt].u = 0, ed[cnt].v = i;}
    	for(int i=1; i<=n; i++) f[i] = i;
    	for(int i=1; i<=n; i++) {
    		for(int j=1; j<=n; j++) {
    			scanf("%d", &xxx);
    			if(i != j&&!vis[i][j]&&!vis[j][i]) {
    				ed[++cnt].u = i, ed[cnt].v = j, ed[cnt].w = xxx;
    				vis[i][j] = 1, vis[j][i] = 1;
    			}
    		}
    	}
    	sort(ed+1, ed+1+cnt, cmp);
    	for(int i=1; i<=cnt; i++) {
    		int x = find(ed[i].u), y = find(ed[i].v);
    		if(x != y) {
    			f[x] = find(y);
    			ans += ed[i].w;
    			tot++;
    		}
    		if(tot == n) break;
    	}
    	printf("%d", ans);
    	return 0;
    }
    

      

  • 相关阅读:
    XML HTML CSS JS的区别整理
    Python的作用域
    python文件操作总结
    python的open文件操作
    python使用struct处理二进制
    webstorm
    vue-cli项目中,配合element_ui来实现上传图片与视频到oss上。
    vue-cli项目中如何实现局部页面的刷新?
    基于cropper图片裁剪,兼容PC端与移动端
    跨域的完全讲解
  • 原文地址:https://www.cnblogs.com/bljfy/p/8946750.html
Copyright © 2011-2022 走看看