zoukankan      html  css  js  c++  java
  • PAT 1005

    1005. Spell It Right (20)

    Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

    Input Specification:

    Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

    Output Specification:

    For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

    Sample Input:
    12345 
    Sample Output:
    one five 

    简单的模拟类型题,没什么好说的。

    代码

     1 #include <stdio.h>
     2 #include <string.h>
     3 
     4 int main()
     5 {
     6     char str[104];
     7     char* const_str[10] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
     8     while(gets(str)){
     9         int n = strlen(str);
    10         int i = 0;
    11         int sum = 0;
    12         for (;i<n;++i){
    13             sum = sum + str[i] - '0';
    14         }
    15         sprintf(str,"%d",sum);
    16         n = strlen(str);
    17         printf("%s",const_str[str[0]-'0']);
    18         for(i=1;i<n;++i){
    19             printf(" %s",const_str[str[i]-'0']);
    20         }
    21         printf(" ");
    22     }
    23     return 0;
    24 }
  • 相关阅读:
    怎样用wordpress建立一个博客
    TCP三次握手
    抓取动态页面
    Controller的激活
    使用PHPnow搭建本地wordpress
    自己动手从头制作WordPress主题探索add_action和do_action
    Cat in dotNET
    如何在本地搭建Wordpress环境
    Windows7下Emacs的安装
    Windows下Emacs的安装
  • 原文地址:https://www.cnblogs.com/boostable/p/pat_1005.html
Copyright © 2011-2022 走看看