zoukankan      html  css  js  c++  java
  • PAT 1015

    1015. Reversible Primes (20)

    A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

    Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

    Input Specification:

    The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

    Output Specification:

    For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

    Sample Input:
    73 10 
    23 2
    23 10
    -2
    Sample Output:
    Yes 
    Yes
    No

    采用素数筛选法,若$i$为素数,则$i*j$不是素数,其中$j=2,3,....$。这样可以不用判断哪个数为素数,因为非素数的都必定会被筛选出来。

    代码

    #include <stdio.h>
    #include <math.h>

    char primerTable[500000];

    void calculatePrimerTable();
    int num2array(int,int,int*);
    int array2num(int*,int,int);
    int main()
    {
        calculatePrimerTable();
        int N,D,len;
        int data[32];
        while(scanf("%d",&N)){
            if(N < 0)
                break;
            scanf("%d",&D);
            if(primerTable[N] == 'N'){
                printf("No ");
                continue;
            }
            len = num2array(N,D,data);
            if(primerTable[array2num(data,len,D)] == 'Y')
                printf("Yes ");
            else
                printf("No ");
        }
        return 0;
    }

    void calculatePrimerTable()
    {
        int i;
        for(i=2;i<500000;i++){
            if(primerTable[i] != 'N'){
                primerTable[i] = 'Y';
                int j,n;
                for(j=2,n=2*i;n<500000;++j,n=j*i){
                    primerTable[n] = 'N';
                }          
            }
        }
    }

    int num2array(int n,int base,int *s)
    {
        if(n < 0)
            return 0;
        else if(n == 0){
            s[0] = 0;
            return 1;
        }
        int len = 0;
        while(n){
            s[len++] = n % base;
            n = n / base;
        }
        return len;
    }

    int array2num(int *s,int len,int base)
    {
        int i,n = 0;
        for(i=0;i<len;++i){
            n = n * base + s[i];
        }
        return n;
    }
  • 相关阅读:
    php 7.1 openssl_decrypt() 代替 mcrypt_module_open() 方法
    关于Http_build_query的用法
    git fetch 和git pull 的差别
    PhpStorm 头部注释、类注释和函数注释的设置
    输出信息log4j.properties的作用与使用方法
    字段设置ALV中下拉列表列的实现
    遍历中序C语言实现二叉树的递归遍历与非递归遍历
    搜索中文Solr Analysis And Solr Query Solr分析以及查询
    记忆指向指针常量 常量指针 常量指针常量
    匹配位置KMP算法深入浅出
  • 原文地址:https://www.cnblogs.com/boostable/p/pat_1015.html
Copyright © 2011-2022 走看看