zoukankan      html  css  js  c++  java
  • HDOJ 2828 Lamp DLX反复覆盖


    DLX反复覆盖模版题:

    每一个开关两个状态。但仅仅能选一个,建2m×n的矩阵跑DLX模版。。

    。。

    Lamp

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 855    Accepted Submission(s): 265
    Special Judge


    Problem Description
    There are several switches and lamps in the room, however, the connections between them are very complicated. One lamp may be controlled by several switches, and one switch may controls at most two lamps. And what’s more, some connections are reversed by mistake, so it’s possible that some lamp is lighted when its corresponding switch is “OFF”! 

    To make things easier, we number all the lamps from 1 to N, and all the switches 1 to M. For each lamps, we give a list of switches controlling it. For example, for Lamp 1, the list is “1 ON 3 OFF 9 ON”, that means Lamp 1 will be lighted if the Switch 1 is at the “ON” state OR the Switch 3 is “OFF” OR the Switch 9 is “ON”.

    Now you are requested to turn on or off the switches to make all the lamps lighted. 
     

    Input
    There are several test cases in the input. The first line of each test case contains N and M (1 <= N,M <= 500), then N lines follow, each indicating one lamp. Each line begins with a number K, indicating the number of switches controlling this lamp, then K pairs of “x ON” or “x OFF” follow.
     

    Output
    Output one line for each test case, each contains M strings “ON” or “OFF”, indicating the corresponding state of the switches. For the solution may be not unique, any correct answer will be OK. If there are no solutions, output “-1” instead.
     

    Sample Input
    2 2 2 1 ON 2 ON 1 1 OFF 2 1 1 1 ON 1 1 OFF
     

    Sample Output
    OFF ON -1
     

    Source
     



    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>
    
    using namespace std;
    
    const int maxn=1010,maxm=510;
    const int maxnode=maxn*maxm;
    const int INF=0x3f3f3f3f;
    
    int n,m;
    bool flag;
    
    struct DLX
    {
        int n,m,size;
        int U[maxnode],D[maxnode],R[maxnode],L[maxnode],Row[maxnode],Col[maxnode];
        int H[maxn],S[maxm];
        int ansd,ans[maxn];
        int LAMP[maxn];
        bool vis[maxn];
        void init(int _n,int _m)
        {
            n=_n; m=_m;
            for(int i=0;i<=m;i++)
            {
                S[i]=0; U[i]=D[i]=i;
                L[i]=i-1; R[i]=i+1;
            }
            R[m]=0; L[0]=m;
            size=m;
            for(int i=1;i<=n;i++)
            {
                vis[i]=false;
                LAMP[i]=0;
                H[i]=-1;
            }
            flag=false;
        }
        void Link(int r,int c)
        {
            ++S[Col[++size]=c];
            Row[size]=r;
            D[size]=D[c];
            U[D[c]]=size;
            U[size]=c;
            D[c]=size;
            if(H[r]<0) H[r]=L[size]=R[size]=size;
            else
            {
                R[size]=R[H[r]];
                L[R[H[r]]]=size;
                L[size]=H[r];
                R[H[r]]=size;
            }
        }
        void remove(int c)
        {
            for(int i=D[c];i!=c;i=D[i])
                L[R[i]]=L[i],R[L[i]]=R[i];
        }
        void resume(int c)
        {
            for(int i=U[c];i!=c;i=U[i])
                L[R[i]]=R[L[i]]=i;
        }
        void Dance(int d)
        {
            if(flag) return ;
            if(R[0]==0)
            {
                ///find ans
                for(int i=0;i<d;i++)
                {
                   int lamp=(ans[i]+1)/2;
                   if(ans[i]%2) LAMP[lamp]=1;
                }
                for(int i=1;i<=n/2;i++)
                {
                    if(LAMP[i]==1) printf("ON");
                    else printf("OFF");
                    if(i!=n/2) putchar(32); else putchar(10);
                }
                flag=true;
                return ;
            }
            int c=R[0];
            for(int i=R[0];i!=0;i=R[i])
            {
                if(S[i]<S[c]) c=i;
            }
            for(int i=D[c];i!=c;i=D[i])
            {
                if(vis[Row[i]]) continue;
                int r1=Row[i],r2=Row[i];
                if(r1%2==0) r2--;else r2++;
                vis[r1]=true; vis[r2]=true;
                remove(i);
                for(int j=R[i];j!=i;j=R[j]) remove(j);
                ans[d]=Row[i];
                Dance(d+1);
                for(int j=L[i];j!=i;j=L[j]) resume(j);
                resume(i);
                vis[r1]=false; vis[r2]=false;
            }
        }
    };
    
    DLX dlx;
    
    int main()
    {
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            dlx.init(2*m,n);
            for(int i=1;i<=n;i++)
            {
                int k;
                scanf("%d",&k);
                for(int j=0;j<k;j++)
                {
                    int p; char sw[20];
                    scanf("%d%s",&p,sw);
                    if(sw[1]=='N') dlx.Link(2*p-1,i);
                    else if(sw[1]=='F') dlx.Link(2*p,i);
                }
            }
            dlx.Dance(0);
            if(flag==false) puts("-1");
        }
        return 0;
    }
    



  • 相关阅读:
    hdu1251 && hud 1247 (字典树)
    linux系统调用kernel code
    Android init.rc 服务启动不成功
    android init执行service的脚本code位置
    printk %pS %pF含义
    进程页表图示
    linux内核之进程的基本概念(进程,进程组,会话关系)
    What is the purpose of the controlling terminal?
    android init.rc中service console option的含义、作用
    启动和停止init.rc中的服务
  • 原文地址:https://www.cnblogs.com/brucemengbm/p/6924904.html
Copyright © 2011-2022 走看看