zoukankan      html  css  js  c++  java
  • HDU 1014 Uniform Generator

    Uniform Generator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 21845    Accepted Submission(s): 8566


    Problem Description
    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where '%' is the modulus operator. 

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 
     

    Input
    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
     

    Output
    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
     

    Sample Input
    3 5 15 20 63923 99999
     

    Sample Output
    3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
     

    Source
     

    Recommend
    JGShining


    此题巨水,可是有坑。

    第一个坑人的地方:英文题。文字太多,让人一看就不想做。而且题目的意思也有点难以理解。

    第二个坑从例子的输出就能够看出。超麻烦的样子,一个不小心就PE了。还得数空格……+_+


    废话不多说。总之非常坑╮(╯▽╰)╭。回归正题……

    题目意思就是说,给出两个数。要你推断这两个数是否互质,假设互质则是“Good Choice”。否则为“Bad choice”。仅仅只是输出的格式非常坑爹,各种空格。PE了几次才过。。。

    每一个数字占10列,数字与字符之间有4个空格)……


    /*
    Author:ZXPxx
    Memory: 1600 KB		Time: 0 MS
    Language: C++		Result: Accepted
    */
    
    #include <cstdio>
    
    int gcd(int a, int b) {
        return !b ? a:gcd(b,a%b);
    }
    int main(){
        char str[2][15] = {"Bad Choice", "Good Choice"};
        int a,b;
        while(~scanf ("%d%d", &a, &b))
            printf ("%10d%10d    %s
    
    ", a, b, str[gcd(a,b)==1]);
        return 0;
    }



  • 相关阅读:
    连接数据库的URL等于多少?
    警告: [SetContextPropertiesRule]{Context} Setting property 'source' to 'org.eclipse.jst.jee.server:20160928' did not find a matching property
    jsp页面中的问题:Date cannot be resolved to a type
    无法找到类:java.lang.ClassNotFoundException: com.tt.javaweb.HttpServletRequest问题解决
    Tomcat无法启动:org.apache.catalina.LifecycleException: Failed to start component 问题解决
    No Suitable Driver Found For Jdbc_我的解决方法
    "aa".equals(name)这种写法为什么就可以避免空指针
    Eclipse迁移到Android studio步骤如下:
    Android 开源框架Universal-Image-Loader完全解析(一)--- 基本介绍及使用
    Android 内存管理 &Memory Leak & OOM 分析
  • 原文地址:https://www.cnblogs.com/brucemengbm/p/7290040.html
Copyright © 2011-2022 走看看