zoukankan      html  css  js  c++  java
  • 2017杭电多校第五场11Rikka with Competition

    Rikka with Competition

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 445    Accepted Submission(s): 366


    Problem Description
    As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

    A wrestling match will be held tomorrow. n players will take part in it. The ith player’s strength point is ai.

    If there is a match between the ith player plays and the jth player, the result will be related to |aiaj|. If |aiaj|>K, the player with the higher strength point will win. Otherwise each player will have a chance to win.

    The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After n1 matches, the last player will be the winner.

    Now, Yuta shows the numbers n,K and the array a and he wants to know how many players have a chance to win the competition.

    It is too difficult for Rikka. Can you help her?  
     

    Input
    The first line contains a number t(1t100), the number of the testcases. And there are no more than 2 testcases with n>1000.

    For each testcase, the first line contains two numbers n,K(1n105,0K<109).

    The second line contains n numbers ai(1ai109).
     

    Output
    For each testcase, print a single line with a single number -- the answer.
     

    Sample Input
    2 5 3 1 5 9 6 3 5 2 1 5 9 6 3
     

    Sample Output
    5 1
     

    Source
     

    Recommend
    liuyiding   |   We have carefully selected several similar problems for you:  6095 6094 6093 6092 6091 
     

    Statistic | Submit | Discuss | Note




    #include <iostream>
    
    using namespace std;
    typedef long long ll;
    int main()
    {
        int t;
        scanf("%d",&t);
        ll n,m;
        while(t--)
        {
            scanf("%lld%lld",&n,&m);
            ll tmp=n*(n-1)/2;
            ll result=0;
            if(m>=tmp)
            {
                result=n*(n-1);
            }
            else if(m>n-1&&m<tmp)
            {
                result=(n*(n-1))+(tmp-m)*2;
            }
            else
            {
                ll p=m+1,q=n-m-1;
                result=m*m*2+(n-m-1)*(n-m-2)*n+p*q*2*n;
            }
            cout<<result<<endl;
        }
        return 0;
    }
    









  • 相关阅读:
    脏数据或者场景考虑不全面引发的生产问题
    框架那些事
    RMI远程方法调用和rpc远程过程调用
    如何提高开发效率
    什么是RPC
    TCP/IP协议和HTTP协议
    apache常见错误:VC运行库(找不到 VCRUNTIME140.dll)
    Apache报错:无法使用可靠的服务器域名
    Apache2.4 下载和安装
    Navicat Premium 15.0.17 破解激活(DFoX 注册机)
  • 原文地址:https://www.cnblogs.com/bryce1010/p/9387437.html
Copyright © 2011-2022 走看看